cRIO Imaging

Hello teams out there this is Team 2853 with a question about Imaging the cRIO.

When I turn on the classmate it says that there is no image on the cRIO. I’m not sure if this means that I have to reimage the cRIO everytime that I turn it on.

So I have tried to reimage the cRIO and I come with a few errors. The first error that I get is that the IP address is unreachable. Other times I get error 56. Sometimes the error message changes even when I don’t change anything in the setup.

Of course there are also times when just restarting the computer makes all the difference and then I am able to successfully load my code.

I am confused. What am I supposed to do?:confused:

Thanks,
Mililani High School (Team 2853)
Mililani, HI

Now as if it wasn’t a hard enough mystery, there has been a new development.:ahh:

I restarted the computer in the vain attempt to see if that would cause the slightest change. As expected, it did absolutely nothing. I then proceeded to try and load my progra another time. After this failed attempt, I exited the developer to see if there was anything I could do from the driver side.

Now here’s the twist:cool: , suddenly all of the lights were green. I appears that the system miraculously communicates with the cRIO. Nothing I did would have caused this change. It appears that I am suddenly able to test programs.

Once again, I am confused. If you can help explain this phenomenon or if you can help make this a little more consistent, I would appreciate that very much.:confused:

Thanks again,
Mililani High School (Team 2853)
Mililani, HI

You only need to use the cRIO Imaging tool once to image the cRIO.

After imaging you need to download a program before anything will happen.

After a program is downloaded to run at startup, the cRIO must be rebooted for it to begin running.
There are ways to temporarily download a program that will go away when the cRIO is rebooted, too.

You might have gotten some of these in a strange order…

Sadly we have tried numerous times. I did do a proper imaging in the beginning, meaning that everything went through properly and it told me that the cRIO was imaged. Unfortunately it repeatedly tells us that we cannot load because there is a lack of communication with the cRIO. Even the driver side tells me that there is no cRIO image.

I am pretty sure too that it is not a wiring problem because we are using a crossover cable straight from the classmate to the cRIO and we are not getting consistent results. Like I said it only works occasionally.

I am convinced that it is a communication problem more than a set up problem. I’m just wondering if other teams have this same problem and what they do to fix it.

Thanks,
Mililani High School (Team 2853)
Mililani, HI