cRIO issues (Imaging and deploying)

Part I:

Team 1713 recently saw a complete cRIO failure - somewhere in the power block seems probably. We contacted NI, and they were absolutely excellent in getting a new one to us ASAP. Our problems started last Friday, and we already have the replacement.

Thank you, NI.

Part II:

The new cRIO was imaged and formatted to Java, then code was deployed. The deploy failed, giving a message about a line in the build.xml file, which when followed, read:

<antcall target="-do-jar-and-deploy" />

After a little looking around, I tried to reimage the cRIO, but the imaging tool couldn’t find the cRIO, even though the connectivity light was on (Ok, now I think to ping it, but I didn’t then). The computer’s IP address was correct. I’ll edit in the results of the ping tomorrow.

After a few searches, I couldn’t find anything similar to this problem. Has anyone else had it, and how have you fixed it?

Thanks for your time!

Look in “2-2010FRCControl System-Getting Started-Rev-0.7.pdf” and follow the instructions for booting into Safe Mode. That should solve your problem.

Which safe mode instructiojns were you referring to? I only saw the section that said to boot into safe mode and run the tool. Is there anything more in depth?

After trying that, I still couldn’t see the cRIO from the scanning tool. A ping also failed, in both safe mode and out of safe mode. While in safe mode, the status light on the cRIO would blink orange three times, then pause for a bit. I don’t know if this is normal safe mode behavior or if it means anything.

Is there a general way to reset the cRIO to factory settings? I see the reset button, but I don’t know exactly what it resets.

Every time I’ve seen the message that the cRIO can’t be found, we’ve been able to solve the issue with a Safe Mode reformat. The details of this are:

-Power down the cRIO.

  • Flip the dipswitch to safe mode.

  • Power up the cRIO.

  • Run the imaging tool. After it runs for a while, it will ask you if you want to reformat the cRIO. Select yes.

  • After the reformat is complete, power down the cRIO.

  • Flip the dipswitch out of safe mode.

  • Power up the cRIO.

  • Run the imaging tool again. It should now image the cRIO like normal.

If this is what you already did, I apologize for the redundancy.

Yeah, this is what I did, thanks.

Any other ideas?

About the only thing that I can recommend would be to try a different ethernet cable and a different laptop. We had one ethernet cable go bad on us this year and that had us pulling our hair out for a while until we switched cables. Also, the network port on my laptop can be a little flaky and I sometimes have trouble reimaging from my computer. It doesn’t seem to have nearly the trouble with other computers, so maybe a different computer might help.

Other than that, try to contact someone from NI. If you are able to get it working, please let us know what the issue was and what fixed it.

Only the standard suggestions: turn off the Windows firewall, and disable any other network interfaces you might have. (One of the laptops I use presents a FireWire network connection, which if active prevents proper imaging of the cRIO.)

Figured it out - wrong subnet mask.

Thanks for all the help!