cRio not reading code (Team 2415)

Hello Chief Delphi, Team 2415 coder here (the team that had to forfeit in the Washington finals due to an unknown cRio bug). Unfortunately it looks like the same bug is back. Here’s what we know.

  • We don’t use SmartDashboard anymore. We thought this might have somehow caused it, and we got rid of any SmartDashboard, but that isn’t the issue if we still have the bug.

  • We are using Java, v47 image.

  • The Driver Station communication light is green, but the robot code light is red.

  • When we try to connect to the cRio it gets to the ‘run:’ statement the cRio never responds (sorry for the vagueness of this statement, I’ll post the full netConsole when I have access to it when class is over).

Thanks in advance for all your help!

Can you post/PM your code?

We are now unsure if its a code problem because it started working right when we tried it today. The errors that we were seeing yesterday was

Waiting to connect to OTA command server of for past Xs

over and over. That error should have meant that we couldn’t FTP, but we could.

We did not change anything with our code, we are unsure…

… and during the time of writing this message the robot stopped functioning. It is now quickly oscillating from having robot code to not having robot code. I don’t think it is code.

And now robot code is working but we cannot ftp.

We’re having a similar problem with our code. We’ve tried updating java and netbeans then downgrading them and nothing has worked.