cRio not working properly HELP!!

So yesterday my team tested our robot and everything was working fine,wireless,labview,and etc. Today, when we came in we made a tank drive labview code and tried to deployed it(we did “build” and “run as startup”). But everytime its in the “Run as Startup” menu we get an error saying that it failed to connect to real time target. We checked over and over and cRio was definitely powered. We tried changing ethernet cables, even labtops but nothing. We then pinged the cRio at 10.28.71.2 which should be its IP address but once again nothing the request timed out. We have no idea what to do. We tried re imaging the Crio but everytime we click apply we get a box saying that the IP of the cRio is unreachable, to make sure that the computer’s network adapter has the same subnet mask as everything else. Also, we tried using NI MAX and we recieve an error. The wierd thing is that we can still use the robot like wirelessly with the driver station and drive it. Please help us we are literally clueless, any help will be greatly appreciated.Thxs :slight_smile:

It sounds like the laptop IP address is incorrect.

One possible reason that it may work to drive the robot is when the Driver Station is set to automatically handle the IP for you. Then it changes back to the original IP settings (usually DHCP-which won’t work with the robot) when it closes.

what should the labtop IP be? we dont use the classmate we have development labtops for programming

The IP address depends on which NIC your are using, but they must be compatible with the cRIO IP of 10.28.71.2
The traditional FRC IP addresses are:

  • Ethernet - 10.28.71.5
    *]Wireless - 10.28.71.9
    We use a netmask of 255.0.0.0

is your driver station running when you try to deploy? An issue came up (bug) where it will not deploy if the driver station is running.

That bug was the Dashboard running, not the Driver Station.