cRio not working...?

We’re trying to deploy the labview code to the cRio. However, the cRio (10.xx.yy.02 and .03 ) ip addresses/devices are not showing up, which (WE THINK) is why we can’t download/deploy anything to the robot. We can see .01 (the bridge), .04 (the ds wireless), .05 (the ds), and .06 (the computer).

My question is, could the cRio somehow be broken/fried and how would we tell? It still has the little green lights that light up when the ethernet cord for the bridge is plugged in.

If you no longer get lights of any sort to come on on your cRIO, then will have a chance to send it back in.

Greg Mckaskle

Actually you have power if the ethernet lights are on. Is the status light blinking?

The little green lights on the red cards are all on. the green light next to the word “power” is on. when the robot is first turned on, the yellow light next to the word “status” lights up, then turns off.
But it doesn’t blink or reappear again.
Still confused, though. (See, I am so not a programmer here!)

Looks like the cRIO successfully booted and is ready. I know other teams have had similar configuration issues - let me see if I can find some posts…

The only thing is, we’ve never gotten to deploy the actual labview robot project code. Everytime it says “trying to connect to the cRio” message and doesn’t get through. That’s why we looked at the linksys manager and found out that the .2 and .3 aren’t showing up. We freaked out that we had somehow fried it. So if it’s all booted and ready and stuff, I’m confused why it doesn’t ever say it was deployed successfully…

Thank you, though! You’ve made me much much less anxious that we had somehow killed it.

Here’s a similar thread http://www.chiefdelphi.com/forums/showthread.php?t=73620

Ok, read through that. I’m not sure what all that means, though. That had a .2 and they were trying to update? We don’t have the .2, and I guess we’re trying to update too. But honestly, I’m clueless. I can get the crio hooked up directly (like the thread said), but it still won’t show a .2 or a .3. I’ll go try again, though.

Thanks again - I printed out that thread to take back to the other room (where the robot is doesn’t have a wifi for internet, only for the crio. sucks!)

be back shortly!!

ok, here i go again.

I tried hardline connecting ds-laptop-crio like the other thread mentioned. Even when plugged directly into the crio, I did not get the .2. Meaning that the computer/system is not reading the crio at all.

Now I’m completely confused, because it was directly connected to it!!

Assuming you have a good link (Enet lights are lit and blinking), can you ping the controller at all? Any reason you might have changed the IP address? Have you read the instructions in the previous link or tried the network address changes?

Assuming you have a good link (Enet lights are lit and blinking), can you ping the controller at all?
…um, ok, will run up there again and ask the other teacher to do that (I’m the math side, he’s the electronics side). But I don’t have a clue what that means, personally.

Any reason you might have changed the IP address?
Nope, and there’s only one IP that we can easily change (the laptop), which isn’t the problem.

Have you read the instructions in the previous link or tried the network address changes?
Read the instructions, gave to jack (the other teacher) to read and make sure we had tried that, but I think the changing of the laptop isn’t the problem - it’s getting the cRio to respond, and we didn’t see that happen when we changed the ip earlier.

But will try again after printing out this thread too, so jack can check that I have done the things you and the other thread suggested.

be back shortly! Fingers crossed…

In the morning, if you’re still stuck, please visit ni.com/first and we can help.

well, we pinged it, and it responded. Very pleased!

Here’s what Jack and I realized might be the issue - our DS is saying"Battery: 00.00V" when we’ve tested the battery on the robot and it is running 12V (actually, when we checked, 12.96 or something.) Wondering if that could be the issue and it’s why we can’t see/talk to the crio?

That’s a good sign! But I’m pretty sure it isn’t the battery voltage. If the lights are on, and you can ping the device then the cRIO is up and running. 12V battery output should result in a healthy 24V going to the controller. It seems like an imaging problem, and you should be able to follow the imaging steps and get up and running from this point.

Wow! You were so helpful last night. Now we can deploy all of it, but 2 things crop up.

  1. During build, it says it prevented a “file name error” or “duplicate file error” or something. We think it means 2 files are named to same thing? Have you any clue how we could find out WHICH file is the problem?
  2. during deployment, it says that it failed to deploy/load startuplibrarypatch.out (i may be missing a space, it was last night). Joysticks and auto mode still do nothing, however.

Any ideas? I have the kids searching the computer/project for the file, but otherwise I’m still stymied, because if it deployed everything else, shouldn’t it work somehow?

THANKS!

The first thing is just a warning. It will happen anytime you use WPI because there are multiple VIs names Open for instance.

The second issue has happened before, but I don’t know the workaround. If you go into the cRIO imaging tool, it has a checkbox for the startup app, and if you turn it off, I think this will go away. I’m sure there is another way to deal with it, but I don’t know off the top of my head.

Greg McKaskle

so i guess the question is, does that one file prevent the cRio from running code? Because after its deployed the rest, we try moving the joysticks or putting it into autonomous mode, but nothing happens. dead robot is not a good robot, even if we are the zombots.

um…so we re-imaged, and thought we had it fixed - and now the status light is blinking, and mocking us.

uhoh.

what the heck does that mean?

What is the blink pattern?

Blink twice then off for 1-2 seconds, Repeat pattern

Jack Gillespie