cRIO plugin problem

After installing and licensing the 2009 control system software from the DVD’s (I attempted to follow the directions) I tried to open up the encoder example in LabVIEW.

I get a warning in the project explorer next to “RT CompactRIO Target”. When I right-click “Explain Warning” I get this message: “The plugin for the selected item is not installed on your system”.

I’ve attached a screen-shot of the error message so you can see what I’m talking about.

The license manager has solid yellow blocks next to all the items mentioned in the activation instructions. Please help me figure out what I should be doing.

cRIO plugin.gif

cRIO plugin.gif

Just a guess here. By chance, did the system you installed the LV software onto from the DVD already have a copy of LV on it?
If so, try un-installing **all **copies of LV and do a clean install from the DVD again.

Thanks for the suggestion. I had LabVIEW 8.5 installed on my laptop (running Vista) before I installed the new control system software.

Today I uninstalled every installed program from National Instruments and reinstalled the new control system software (it took hours). Unfortunately, I still have the same problem.

I didn’t have a problem when I installed the software on a desktop running Windows XP. That computer had never had LabVIEW installed.

What should I try next?

Problem solved!

I had to do a clean install (including registry editing) using instructions from NI’s help forum. I’ve attached the instructions in case anyone else needs to do the same thing.

Clean Reinstall Procedure for FRC Control System software.doc (28.5 KB)

Clean Reinstall Procedure for FRC Control System software.doc (28.5 KB)