cRIO Problem

Oh what our team breaks…
So I was testing our cRIO with my code, and when I first booted up the robot I noticed that there was already code on it for some reason (we had it reimaged at kickoff and I hadn’t deployed any on to there, just ran from the computer). So I went to go reimage it. I followed all of the instructions, and it was going fine, until I get an error. I don’t have a picture of the error at the moment, I will get it later, but it basically said that there was an error (error60 to be exact), and then it gave me a list of file. Later down in the explanation, it said the IP for this device was in use. I checked the lab, made sure all the computers were off, as well as all phones. Went to go and run the image and saw that the driver station wasn’t detecting the cRIO and LavVIEW couldn’t deploy to it. When pulling up the imaging software, the settings of the cRIO had been completely reset including IP. After trying to run the image again, I got the same error. I then turned the cRIO off, and rebooted in in safe mode so that the imaging would reformat my cRIO. I did that with no errors, and still ended up with the exact same error as the first time.

I’m completely stumped here. I followed all documentation and tried to look up as much info as I could on this issue, but I had no luck. Any suggestions? I plan to contact NI about it but we already have about 60-70% of the robot built (including drive) and we really need to test it to see if it works.

Thanks so much in advance if you can help!

According to the How-to PDF, on your last attempt to fix it, you:

  1. Installed all of the updates
  2. set your IP address to 10.34.13.6 (10.34.13.5 on the classmate)
  3. connected the cRIO to your computer via an ethernet cable
  4. switched the cRIO into safe mode
  5. ran the imaging software to format the cRIO
  6. switched the cRIO out of safe mode
  7. ran it again to apply an image
  8. Built and deployed code
    ?

Yeah I did those steps, minus the run and deploy code because LabVIEW could not connect to the cRIO. I still get the error.

I’m going to throw this out there because we ran into it tonight.

If you install the imaging tool on a computer that already had it from a previous year you end up with 2 copies of the imaging program. One in the LabView 8.5 folder and one in the LabView 8.6 folder. The shortcut on our desktop got changed but the one in the start menu did not and this stumped us for a while. Because we were running last years or maybe even the crio imaging tool for the year before and got an error that I do not remember off the top of my head.

The other problem we had which probably seems obvious to most people but I will throw it out there any ways because a new team member failed to do it and it caused problems is entering the team number in the imaging tool.

No guaranties, just the problems and the solutions my team ran into when we imaged our cRIO.

Thanks for the help, but we finally got it resolved. The issue was with the firewalls. Error 60, then sequentially error 1 are firewall errors. Just if anyone else wants to know.