cRio refuses to work with newest driver station


Our old 4-slot cRio does not want to communicate with our 2015 driver station. The light however on the driver station is half red and half green, but the battery does not show its voltage for whatever reason despite switching the DS protocol to 2014. I’ve re-imaged the cRio to v52 (unable to find v57), loaded the program on with the netbeans IDE and plugins, changed the ip to .5, .6 and .8, tried an OLDER driver station and just about given up.

Does anybody perhaps have a v57 cRio image I could use, I think that will (hopefully fix the problem)

team 4012

What Java version are you attempting to use on the old 4-slot cRIO?
The version used for the roboRIO is not compatible with the cRIO which used a different/older version.
I believe v52 is the correct FRC image for 2014.

You can use the cRIO if you still have an old original Java user program installed on it, but you won’t be able to make modifications.
Or if you still have an installation of the older cRIO Java version on a PC that can be used.
Otherwise, LabVIEW is the only really supported cross-compatible language.

Well I’m not sure what java version the v52, I believe I’m using 6 to build the program though. Do I have no choice but to use labview if this is the case?

Java 6 is too modern for the cRIO version inplemented for FRC which utilized the Squawk VM.
It used Java 2, I think the cRIO used source level 1.3
You might be able to use a tool such as RetroTranslator to downgrade your code, but I haven’t tried it.

Is there somewhere to download the old software?

That’s very odd, as the frc website said it used java 7. I seem to get compiler erros with the jdk 2 on netbeans, any advice

Do you have the WPILibJ2014 version of the FRC Java libraries?
Make sure to use matching or compatible versions across the board.

Here, a friend just let me know that the original files are still posted here: