cRIO reimaging error...

Hi, all.

We’re trying to reimage our cRIO from the 2011 to 2012 image, and although everything is set up correctly (IP addresses are right, subnet mask is fine, the crossover cable is plugged into the right port, and the robot is even on) when we try to run the 2012 cRIO Imaging Tool we get an error that says “No CompactRIO devices were found. Verify the network connection.” If we open up the 2011 imaging tool the cRIO is listed as being there, but we can’t update the cRIO with it (I’ve heard it’s because it’s such a different image that you need to use the 2012 imaging tool). Our mentors and I have been tearing our hair out for the past two days over this, so we really need some help. :confused:

Has anyone else had this problem/resolved it?

Have you tried turning off the windows firewall?

Did you also install the LabVIEW update on the business-card thumb drive in the KoP? The new imaging tool will no run properly without it.

This happened to us and all we did to fix it was use a different computer to do the reimage. I think you just have to make sure you have everything installed properly: the software on the KoP USB drive, the Utilities Update, and the Driver Station Update.

The CRIO imaging tool no longer finds the target device following the upgrade to V43 and the move of the boards/modules to their new 2012 locations in last years 8 slot cRIO.
slot:
1 9201
2 9403
3 9472

I can run projects, ping the device, turned off the firewall and no luck with the imaging tool finding my target.
While the image is up to date I’m concerned that I’m now stuck on this image and won’t be able to upgrade if necessary.
Software is all up to date, utilities and updates installed.

If there is someone out there that is using last years cRIO with the v43 image and the modules moved per p12 of the getting started with cRIO doc that can is not having a problem with the imaging tool finding your cRIO on the network please let me know. It’s easier to fix something I’ve done wrong than have this be a bug with the tool.

Mine works fine.

Did you turn off your firewall and anti-virus?

OK having that information gives me some confidence to keep plugging away at it. I decided to push forward with other things today.
I did turn off the firewall but didn’t associate the anti virus with this kind of issue.
Thanks again Mark!

We spent 4 hours troubleshooting the same conditions. It turned out to be bent pins on slots 1 and 2!!! When your cRIO is discovered, do all the modules appear? Before we noticed the bent pins, we removed the modules and tried to image again and it worked. Surprisingly, we were able to bend the pins back and none of them broke off:)

It’s working now, my FRC shows three green boards.
I’m not sure that this was the problem but I had the 25 pin analog and digital breakouts swapped on the modules. Not being that familiar with them I had them swapped.
I guess I could try swapping them again to be sure but I have too much to do!

I had the same problem of the reimaging tool not finding my eight-slot cRIO while trying to upgrade from the 42 image to the 43 image. I was stuck for quite some time.

The last two things I did, in order, before the reimaging tool finally found the cRIO were:

  1. Installed the LabVIEW_Setup.exe from the KOP USB widget (even though we’re using Java so didn’t expect to need it).

  2. Turned off Windows Firewall.

I believe I had (re)installed the FRC_Tools_Setup.exe from the KOP USB widget recently, too (already had the tool, but it may have been an older one from the 2012 Beta).

David