cRIO updating to v43 Image issue

Hey everyone.

I’m just getting ready for the 2012 season and tried to update my cRIO’s (old cRio) Image to v43, as Wind River requires it.

Unfortunately, when i attempt at updating it using the Imaging Tool, i get the following error:

Unable to complete operation because of unexpected error 7:
File/Directory Info in><APPEND>
C:\Documents and Settings\Owner\Local Settings\Temp\lvtemporary_515166\CRIO

Updating to an older Image seems to be fine.

In addition, I’ve tried using the NEW 2012 Imaging Tool, and it doesn’t even recognize my cRIO.

Has anyone here encountered this problem? how can i resolve it?
Thanks in advance.

Due to major changes in the image format to handle multiple types of cRio’s, you MUST use the 2012 imaging tool for the 2012 image.

As to it not recognizing the cRio, can you post more information?

Thank you for your reply.

I believe my cRIO’s IP is configured to be 10.22.13.(2?) and my PC is
configured to

As i’ve said, the old Imaging Tool DOES recognize it. and it can successfully flash older Images.

Please tell me if you need any info that i have not mentioned.

Nevermind! I’ve managed to get the new Imaging Tool to recognize my cRIO. I’ve done this by restarting my PC and the cRIO itself.

However, when flashing the new v43 Image using the new Imaging Tool I’ve ran into the following error:

Unable to complete operation because of unexpected error:
Error 15 occurred at Call Library Function Node in>>>

Possible reason(s):

LabVIEW:  Resource not found.

Could this have to do with the fact that i haven’t installed the things from the NI USB? If so, where could i get the appropriate files? since i don’t have the USB currently with me.

Do you have any other ethernet adapters enabled? We saw weird issues in the beta test (although only with the new cRio) if any other ethernet adapters were even enabled (let alone connected).

What image version does the imaging tool show? V43? What version is the imaging tool?

I honestly don’t know how the imaging tool will handle several versions of the imaging tool at the same time. We were told to uninstall everything old and re-install everything again, I would recommend that next.

+] I have disabled all other adapters as i have had problems with it before.
+] the Imaging tool attempts to flash the v43 image.
+] the cRIO currently has the v20 image.

And if i want to uninstall the old Imaging Tool to try and solve this, how would i go about that?


The 2012 Imaging tool will require the FRC Tools install from the NI USB to function properly.

Myself, Everytime I try to open anything from the labview utilities tab on the FRC 2012 update nothing will open. The only thing that will open is the programmer for the boards. Axis setup wont open, cRio imager wont open. Etc.

Anyone else having this issue?

Have you installed the Utilities Update?

On a related note, I saw the behaviour described by the OP when trying to use the 2012 reimaging tool under Windows XP Pro (did not recognize the cRIO, but the older update tool did). I did not encounter any documentation for this application that stated what OS was required, so I wasn’t really suprised that it didn’t work under XP. Using a different laptop with a Windows 7 OS the same 2012 reimaging tool was able to recognize the cRIO.

It’s entirely possible that there was something else going on (non-obvious adapter differences between the two laptops, etc.). Has anyone been able to get it to work under Windows XP? Or found any documentation stating that it shouldn’t/won’t?

I myself got it to work under Win XP. i described above what i have done.

I have also been having some issue re-imaging the cRIO to v43. I am using the old cRIO and a Windows 7 OS. My NI LabView is installed along with the newest java, which we are programming in. We are using a non-classmate driver station to try to update. The IPv4 is configured like this:

IP address:
Subnet Mask
Default Gateway

I have the computer plugged into the first link port on the cRIO. The power is on. Everything electrical is setup correctly. When trying to run the 2012 Re-Imaging Tool, I get the error message that says “No CompactRIO devices were found. Verify the network connection”

Any help would be most appreciated!

I had some issues updating today, and the issue was having more than one network adapter enabled. Even though I was not connected to any wireless network, I consistantly got a timeout error while formatting. Turning off the wifi card fixed this. I hope this helps someone out there

If this has any value, I solved my problem by installing FRC Tools from the NI USB…

This is caused by having not installed the utilities update. Sounds like you only have the driver station update.

Ah, alrighty, Ill look for the update I missed later today then. Thanks!

When trying to put the new image on the cRIO, I keep getting this error message:

"Unable to complete operation because of unexpected error:
Error -2147220308 occurred at

Possible reason(s):

NI System Configuration: (Hex 0x800404AC) Could not contact remote target. Ensure that the system is online.

Complete call chain:

I uninstalled all of my NI software from last year, and installed all of the new software for this year including all three updates in the correct order.

My adapter settings are as follows:
Wireless adapter: disabled
LAN: IPv4: IP Address: Subnet mask:

I have the ethernet cable plugged into port 1 on the cRIO.
Safe Mode and the other switches are off.

The 2012 cRIO Imaging Tool is detecting the cRIO’s MAC address, IP address (, and name, but says that the current image is unknown.

What am I missing or doing wrong here?
Any help or advice would be greatly appreciated!

Can you FTP into the cRIO? You can test this by typing “” into Windows Explorer.

I encountered that error while imaging an old cRIO?

  • Disable (right-click and choose “Disable”) all NIC’s, but the one Ethernet port you are using for the cRIO
  • Use an intermediate switch between the laptop and the cRIO
  • You can try a Safe Mode reformatting (Safe Mode dip switch. reset the cRIO, run Imaging tool, turn Safe Mode switch back off, reset cRIO)
    *]Followed by a regular Imaging

I could not FTP into the cRIO, but after doing a Safe Mode reformatting, it imaged properly.

Thank you so much for the help and the quick responses!