CTRE CANcoder dependency issue

Currently getting a dependency error for a library that came installed with Phoneix Tuner 1.7.0. I tried to follow this thread but 2022 WPilib doesn’t have a deployFrcCppLibrariesRoborio task (not sure if it’s supposed to). This prevents me from deploying (as shown in the image above) creates a file not found error.

From where do I move the file from my host computer to the roboRio? My understanding of how gradle works is that it does install the dependencies so technically I should just be able to SSH in and move the file myself but I’m not sure where I move it from (on my host machine). Furthermore, is there a solution that works in 2022 Wpilib so that I don’t have to move the file in myself? I looked at the gradlew tasks and deploynativeZipsfrcJavaroborio seemed to be the most likely one but I ran it and the problem still persisted.

It looks like you aren’t using the 2022 version of the Phoenix library.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.