CTRE Mag Encoders are skipping

We are having issues with Mag Encoders. Every once a while, the encoder will skip while the talon is running its position control. The encoders are in a Vex Pro hex bore, which we disassembled and confirmed is working properly. The encoder wire is long, but we’ve replaced it twice. The encoder has also been replaced. We We theorized the long wire experienced electrical interference, but the skip is consistent. The talon has also been replaced. Has anyone has any experienced any similar problems, how have any debugging suggestions? We have scoured the code, and are not zeroing the encoder anywhere.

We’re going to need some more information. What mode are you running in? Absolute or relative? Where is the encoder getting power from? How much of a ‘skip’ are you seeing?

Are you browning out at all?

You have installed one of these in a hex bore?

http://www.ctr-electronics.com/sensors/encoders/srx-magnetic-encoder.html
http://www.ctr-electronics.com/sensors/encoders/cancoder.html

The encoder skips in both modes, by about 30 ticks. We replaced the encoder with a potentiometer, which has so far worked, so the code is not the issue. We have experienced brown outs, but the encoder skips even in absolute mode.

30 ticks on a 4,096 tick per rotation encoder is less than three degrees. Does this happen when you stop or reverse direction or otherwise change speed significantly, because that’s not out of line for backlash (play between the encoder and the actual item being measured).

1 Like

When you say you verified that the hex bore is working properly, did you check to see if the magnet inside the hex bore was not damaged? Have you tried using another hex bore to check if it also exhibits the same behavior?