Cypress Board not recognized by non-classmate

we can get our classmate to see the cypress board but not our pc, configured like a driver’s station. we also purchased the estop custom control interface board

it works beautifully, thanks estop and only cost 40.00.

but we believe we should be able to get our new cypress board working too.

we have purchased a new cypress board
CY8CKIT-003, although digikey was selling a CY8CKIT-003A. don’t really know if there is a signficant difference.

we have tried uninstalling and reinstalling all cypress software, still cannot get our non-classmate pc to see the cypress board.

on the classmate, we can see the psoc board via the I/O tab but not on any other pc.

we have read the first forums post, simliar to this but i’m not sure it the folllowing post applies to us

any help here?

Did you check if the CyMiniProg3Service is running?Check it (XP) under Start -> Services -> Control Panel -> Administrative Tools -> ServicesWin 7 is similar but I don’t have the menu path memorized.Did you install the Cypress DVD by accident (or on purpose), or run any online updates onto your other laptop?

You can check the Cypress versions:
Cypress PC program – Start->Programs->Cypress->PSoC Programmer 3.12

  • Driver Station Install (correct version)
  • Update from Online 3.12.4+ (user did an online update - incorrect)
    *]Cypress DVD case (user installed the Cypress DVD – incorrect)
    I haven’t verified that this year hasn’t changed these versions though.

we did not use the dvd that came with the board and i think we did check for the service running under windows.

i know we are running the updated driver’s station.

i will verify all these items tonight.

thank you for the helpful post.

Did you reprogram the Cypress with the programmer and the hex file installed with the utilities update? Without this, it won’t be recognized.

we did

We got our cypress board working. The problem started we believe when we used the vendor supplied DVD as a starting point.

We ended up fixing the problem from an extremely helpful post on first forums, giving dll sizes. When we deleted the dll and replaced it with one from the classmate, using the file sizes as a guide, all worked.

We have made all the driver’s station updates. We assume the vendor DVD put a bad dll out there.

thanks to all who helped.

i still like the board from estop robotics better, it works everytime, no issues.

The files actually come with the driver station update.

My bad… I knew it was one or the other…
Hence my signature :stuck_out_tongue:

The “correct” version didn’t change, but I feel certain the DVD version would have.

One tip that can help teams that have installed the Cypress driver update from the web is that this can be made to function properly by copying the Program Files\Cypress\Programmer\3.12\Service\ftk_3_simfw.hex from a properly installed Driver Station. This is the file that gets overwritten by the Cypress update. The Driver Station needs this particular version of the file to read data from the board. The size should be 29,663 bytes.

Be sure to refer to the new Cypress troubleshooting guide at the end of the “Getting Started with the 2012 FRC Control System” document on