Cypress installation order

I did this so many times last year without a hitch, and now I’ve got a new installation (Win 7 Pro x64) where the Driver Station doesn’t detect the Cypress board. (The board works on other laptops with same OS - although the CyMini service sometimes needs a restart).

The driver looks good - it shows up as FTK3 - configured. The PSoC programmer connects to it fine. The CyMini service is set to auto and running. One thing that is different is that when I installed from the Cypress disk, I ran the updater, so the PSoC Programmer version is 3.12, not 3.10.

Maybe I’m installing in the wrong order this year. Here’s what I did:

  1. Install LabVIEW original files
  2. Install LabVIEW update 2.1
  3. Install DSUpdate 1.1
  4. Install Cypress disk - everything set to Typical
  5. Ran the Cypress Updater

I ran the setups as admin and re-booted after every step. When it didn’t work I un-installed all and tried it again.

Is this correct?

David

I just reimaged a Classmate and reinstalled everything, but I haven’t tested the Cypress board yet. I don’t run the separate Cypress installations that you added at the end.

I’ll try it with the Cypress board as soon as I get home after work tonight and see if I have the same or similar problems.

When doing this on Win7, I needed to update the .hex file in the specific programmer. I believe I took the ftk_3_simfw.hex file from a working classmate and placed it into the ProgFiles/Cypress/Programmer/3.12/Service folder overwriting the one that was already there.

I can’t remember the exact file or location, so if that isn’t it, it was a .hex file that I moved and placed near a Cypress service.

Greg McKaskle

I’ve seen those files in similar locations - I’ll try it.

Thanks Greg.

David

10 minutes later and it works - just as you had it. I had tried moving the driver PSoCUSB.sys from the classmate last night, but that didn’t work.

Thanks again.