Cypress PSoC 3 driver problems

We plan on using our control board from last year. I have installed everything that comes on the CD for the PSoC 3 board, and I have installed the PSoC programmer 3.17 right from Cypress’s website. When I open up device manager, I get an Unknown Device message.

I am currently running this on Windows 8, so that may be the problem.

If anyone has any idea of how to get Windows to recognize the board so that I can set up the Configuration in the Driver Station and start programming this thing in LabView, thank you. I’ll provide any information as needed.

-Landon, Team Fusion 364 Programming

You probably have the wrong version. See

I have been successful with the board on other computers that were configured correctly. I also programmed it to do certain fuctions with a proto bot.

I’m sure that the firmware is loaded correctly and that this is most likely a computer issue.

Edit: I have gotten the drivers installed. I will upload firmware asap just to make sure that it is up to date.

Now that I have gotten the drivers installed on our laptop, I tried testing the board in the driver station. It isn’t working.
I went to the old computer that it worked on and it isn’t working on that one now. I’ll see tomorrow what i can get working.