Cyprus Not connecting to FRC Labview Driver Station


We just got a new Cyprus, but when we hooked it up to the driver station, it didn’t work. The light turns green on the cyprus board, and it connects fine to the laptop to program it, but the Laptop gives the error: “FRC: Custom I/O is not enabled or is not connected to the driver station” I tried using the PSoC Programmer Utility to configure the cyprus, but the one .hex file we have (FRC_IO.2012.v3.hex) doesnt work. The programmer returns the error “The hex file does not match with the acquired device, please check the device” I’m not sure where to go from here. Any ideas?

It depends on the exact wording of the error message.
See this thread and if it applies to your error message:

Our team resolved this issue earlier today in a strange way (I’m on 1732 as well). We tried running the PSOC programming tool on a different laptop, and when we went to select the image file, there was not only a 2012 image but also a 2009 image. This was a laptop purchased in 2011. The 2009 image went onto the PSOC fine, and everything seems to be working for now. Obviously not optimal, but working.

If it took the firmware, then it was the right one.
You can tell by pressing the only button on the Cypress board. It will light up red LEDs reflecting the firmware version. No lights means no FIRST firmware.

There are three versions of the Cypress FirstTouch out there now.
The PSoC Programmer checks for the board version before loading the firmware and won’t load it if the version doesn’t match the firmware.

The first two Cypress versions take two different FIRST firmware versions (yours obviously requires the 2009 version, so it’s an older board).
The third version requires an updated PSoC Programmer to recognize the version at all, but while the latest PSoC Programmer can recognize the Cypress board version and install the firmware, having it installed breaks some other FIRST tools.

Thanks for the help! We’ll keep that in mind in the future.