D-link dropping out

our wireless network bridge keeps dropping out when we run our robot.

one of our mentors thinks that the voltage to the bridge is dropping causing the connection to fail.

is this possible or what else could be causing this?

Is the bridge running through the 12V-5V convertor connected to the dedicated 12V supply on the end of the Power Distribution board? (not the regular 12V connectors along the long sides)

Hello, and welcome to the forum!

Before I start, I’d just like to tell you that generally it is frowned upon to create a user with the name “helpme”. Forums are about helping others too, so yeah!

Anyway, we need to know a bit more about your robot. Are you supplying the bridge with power from the 12 volt converter?

What is defined at “dropping out”? Does the radio reset and do a full reboot (like you just turned on the robot)? Or does it just drop out for a few seconds?

This may seem unrelated, but are you using a 2CAN on your robot? We were, and it was causing us to loose communications with the robot, sometimes for a moment, sometimes indefinitely.

We suffered with this more than I like to admit last year.
First off, make sure the 12v to 5v converter is properly connected to the +12v out from the PDB. Not just a breaker, but the +12v dedicated for that purpose.
Next, and this is what turned out to be our whole issue, make sure every connection in the wiring between the PDB and converter are solid as well as the output from the converter to the radio power plug. We had not one, but four, pour soldered connections. Once we found those and made them right, we had no more issues.

Watch the radio next time it fails, if it is rebooting, you can be sure the issue is on the power side. Additionally, if you gain control again after about 45 seconds, that also indicates a radio reset.


when we turn on the robot the wireless works but when we move the bridge manipulator/ ball elevevator the connections stops and we have to reconnect from the driverstation.

no we have pwm.

also we just bout a new d-link.

It might be interesting to hook up a multi-meter to the wires that go to the wireless bridge and see if the voltage drops when you loose comms.

Also, just generally watch the lights on the robot and the bridge to see if anything changes from normal behavior.

Just out of curiosity, what is the battery voltage doing when you lose communication, watch the graphs in the DS and check to see if you bridge manipulator is draining all the power.

Are you sure it is the wireless losing communication? Is it possible that something isn’t running right and drops the voltage so low the crio is rebooting? I guess in short, do you lose communication, robot code, or both?

What proof do you have that your bridge is actually dropping out?

The dedicated power output functions down to a 4.5V input, and it takes a lot to force a voltage dip big enough to bring you down that far.

will try this thnx.

we just lose communication.

communication with the robot is lost…

We realize that communication is dropping out. What we don’t know is why.

Every question we ask here is aimed at finding out why it’s dropping out, so you can fix the root cause of the problem. There are a few possible reasons that comms can drop.

–Voltage could be dropping really low (see the *battery voltage check *request), which opens up a few more places to look for the problem.
–A non-electrical problem could be cropping up. How’s the Ethernet connection holding, and is it loose?
–Lights will tell a lot. What are they doing, particularly the ones on the cRIO and the bridge?
–Do comms drop out under any other conditions than the bridge material/ball collector moving? If no, then it’s going to be somewhere in that mechanism. Is it pulling a cable, or close to the D-link?

Strain relief the 5v connector that plugs into the back of the Dlink. A jolt will jiggle the connector and cause a voltage drop to the radio. We secure the cable and tape our connector down in competition

A** DMM might not see a drop out of brief time that will cause this problem.**

An oscilloscope is preferred Voltage Vs time instrument but time consuming
Solicit an EE mentor to expedite scope usage.

A digital storage scope will view long time unsynced scan (DSO)
Seek out resources you have or can borrow.
Since problem is mystery, initially use long scan duration, if blob drop out is evident
try external sync to your suspected motor with faster scan to see detail over time of “glitch” or other suspected devices to determine root cause to fix.

Teams at each regional will have a scope for these hard time related problems: sagging bus, intermittent shorts, (RS-775?),

Potential Problem Note: high powered motors: **CIM RS775 & FP stall current each is over 100A **

all motors start-up with a high brief stall current “glitch” ~50ms-350ms (low mass shooter - drivetrain)
depending on load mass, acceleration to speed varies as a function of gearing.
if geared too fast (like direct drive), glitch is longer, due to less torque available to move load to arrive at higher end speed

The longer & higher peak amplitude the spin up glitch, the lower the voltage dips to all other loads, especially sensitive electronically controlled ones for a longer time, potentially causing reset, drop out, reboot, jerky action, noise induced indeterminate’s etc.

It is important to identify such basic problems early; gear changing can be challenge in the heat of competing.

For sure make good mechanically solid low resistance crimps, minimize insertion cycles of critical connectors and autoReset Breakers (20, 30, 40A) loose fit/crimp/screw = higher contact resistance! use welding cable stranded wire of heavier gauge especially on longer runs for less tension on connections and less path R.

competition batts drop ~1v at battery terminal for every ~50A drawn typically
then add Vsag from robot wiring resistance to load in question.

2 CIMS stalled draw 2x133A 266A causing >5v sag **at fully charged batt terms to 12.6-5= 7.5v **
could be trouble once rest of wiring connection resistance is added say 5v or less at load for a few hundred milliseconds??

Excluding average state of charge battery Rinternal = .020 ohms
Is rest of your the total serial current path out & back to batt consisting of connectors, crimps, wiring, 2 breakers, total less than .010 ohms? if exactly then .01*266 = another 2.66v GONE! 7.5-2.7= 4.8v at load end voila!!

Good Luck … hope this inside knowledge may help find the culprit…

I’ll be at LA (=Long Beach) & STL as bearded iridescent green capped RI to help teams with tough electrical problems.

I cannot emphasize more how correct Eric is. Although loss of communications is generally symptomatic of a bridge problem, keep in mind that the problem can still lie elsewhere. The most conclusive and definitive way to determine if your bridge is power cycling is to observe the lights on the bridge and to see if they all turn off. If so, then you can be certain that your bridge is indeed cutting out.

Another suggestion to consider is a secure power connection - does the barrel connector going into the bridge ensure a steady power supply, or does it wobble out when you run the mechanisms at fault?

Please clarify what you mean by “reconnect”. Are communications restored by themselves after you lose comms? If so, how long does the reconnection take? If not, what do you have to do to reestablish communication?

Just had a similar problem and sure enough, you’re trouble shooting recommendations worked. We were pressing the Enable button on the driverstation (the soft button) and then losing comms immediately. I had somebody eyeball the robot and it turned out that when I pressed the Enable button, it looked like power cycled on the robot. We noticed an error indication on a drive wheel Victor, so we replaced that Victor. We’re back in action! Thanks folks!

It seems that your DAP is powering off due to a voltage drop or surge of interference. At the Kansas City regional, we had a similar problem with an Axis 206 camera: whenever we moved our bridge arm, the camera would power off. we fixed this problem by isolating the camera from all metal, supporting it with a piece of polycarbonate plastic. Try isolating the power wire from those running to and from the Jags or victors.

There is a failure mode on the 5 volt convertor that will send 7 volts to the radio on full battery voltage and then as the battery goes down so to does the output of the convertor. It acts just a like a resistor. I believe that the failure mode is caused by a reverse electrical connection at some point. Double check the output voltage of the convertor.
Blackflame, the camera body is connected to the negative lead of the power supply. If you have other frame shorts, it is possible to shutdown the power supplies in the PD as reported by it’s designer.

Depending on the model of wireless adapter in use, the proximity of speed controllers to the wireless may have play in the issue. My teem found a few years back that when the speed controllers are running at a high voltage, the EM radiation produced can mess with wireless if the wireless is only a few inches away. An easy way to test to see if this is an issue is getting your wireless as far from your jags as possible (even just duck-taping it at max cord length works). Keep in mind that moving it may also solve other issues.

We were having this problem at LA also. First of all, if you see that your bridge turns off during a match, check the power wire to the bridge, to check for any breaks in the wire. Also, any soldered connections should be resoldered. If this still doesn’t work, just replace the whole wire. Also, it could be a problem with the DC to AC converter. If you are getting power to the bridge, but are still having problems, you may want to check your ethernet cable.

We have also been getting D-Link drop outs. During our competition at Traverse City and at Western Michigan District we had several communications drop outs. Our robot was not driving hard and no major current draws on the battery. The Field controls personal said our radio reset. I am questioning this answer because I see the radio takes about 1 minute to power-up and starts its wireless communications. We loss communications for about 40 seconds. After 40 seconds we are off and running again. My thoughts are we having a wireless network access point/network problem on the field control access point. We saw several other teams with the same problem at these two events.

part of getting connection at startup is the c-rio getting started up. It takes less time for a router to just reset since the c-rio isn’t starting up again.