Dashboard Won't Show Up!

I’ve modified the current dashboard to include an indicator for a sensor switch on our robot. When I run the executable in the Developer account, everything shows up fine, but when I log into Driver no Dashboard shows up at all. I overwrote the new Dashboard.exe in the original’s location, so it isn’t a location issue. I looked into the INI in the Shared Documents and saw the filepath was screwed up (it replaced a few letters with zeroes, and switched two letters). Every time I log onto Developer I change it, but after logging in and out of Driver the path is back to it’s screwed-up state. Does anyone have a fix for this, or possibly a link to the original INI so I can troubleshoot before I decide to flash the DS?

Update: I replaced my new Dashboard with an unmodified new Dashboard project. This still did not work, so I think I may have narrowed it down to a Windows Firewall or INI issue.

I was just making a dashboard for our classmate, and at first, I had the same problem. I did change the file directory for the .ini file, and it worked. Were you using LabVIEW, or C++? I was using LabVIEW, but that shouldn’t make a difference because it’s a .exe. The only thing I can think of is if you saved the changes you made to .ini. I hope this helps.

While the DS is loaded, it keeps the path in memory. If you change the ini file, then the DS saves the file on exit, your changes will be overwritten.

Does this explain it?

Greg McKaskle

Somewhat. Thanks for the help.

After restoring the Classmate (I couldn’t solve the INI problem), I’ve decided to stick with the default DS, because, after all, it’s just one LED I was changing the size of.

I was having the same problem, changing the path in the.ini file and after the driver station runs it garbles the path up.

I went looking around, then found that the name of the item that specifies the path should be “DashboardCMD Line”, not “DashboardCmdLine” like it was. Changing that fixed it.