Dead RoboRIO?

Last night at our team meeting, we were met with an unexpected RoboRIO failure during our fall training session. I had one student deploy code to a test board to test her work, and everything worked as expected. I then had a second student then deploy her code to the RoboRIO, and she was met with this error which I’ve never seen before:

On the off-chance that there was some problem with her laptop, I attempted to deploy my example code to the RoboRIO, as I had done several times over the past few weeks, and I was met with the same error. Same thing when trying to re-deploy the first student’s code to the RIO.

After some preliminary poking around, I ended up completely removing all WPILib installs from my laptop and re-installing the latest 2023 WPILib and was still getting the same error when trying to deploy any code to the RIO.

I then thought I would try to re-image the RoboRIO. I fired up the RoboRIO imaging tool, and it could not detect the RIO when connected with the USB cable, even when running the tool as administrator. I disabled my WiFi and turned off all firewall settings, and still couldn’t see it. I deleted and re-installed the latest 2023 FRC Game Tools from NI, and then I was able to see the RIO, but only while the RIO was restarted in safe mode. When trying to reformat with the latest image, I was met with this error.

When trying to update the firmware of the RIO, I was met with yet another error.

I’ve already opened a support ticket with NI to see if they can help, but was curious if anyone here has seen this type of behavior before and what, if anything, you managed to do to fix it. Currently, my best guess is that the main storage (I’m assuming eMMC, NI’s documentation doesn’t get very specific here) has died, and that the entire unit will need replaced.
I will be sure to update this thread with whatever resolution I end up getting from NI.

1 Like

Having The Same Problem Here, We Have A RoboRIO Like That For Already 4 Months and we dont Know what to do. Tried To Fix it With all Of The “Possible Solutions” But Didn`t Qutie Work

If Anybody Knows What To Do It Would Be Very Helpful. Also it Was The RoboRIO 1.0

If you tried the safe mode as well and it didn’t work, you should reach out to NI, they’ll help you out:

1 Like

Roborio 1 or 2? I assume 1 but If 2 try replacing the SD card. Otherwise contacting NI might be the best bet. We had something similar when an SD card failed.

1 Like

This is a RoboRIO 1. I believe we would have purchased this one around 4-5 years ago, but I’m not entirely certain how old it is. I provided the serial number to NI in my support request, so hopefully they will be able to use that to determine its age.

The Safe Mode recovery instructions are here -

Based on the messages it appears the Rio is not completely bricked. So, did you try reimaging it in a safe mode, by any chance?

1 Like

We reached out to NI and will update the thread with their response.

Yes. The RIO couldn’t be discovered without safe mode, and the image/firmware errors were seen in safe mode.

Knowing that this RIO is decently aged and has been used on test boards for a while, our guess is that part of the eMMC chip failed. This would explain the corrupt firmware and inability to write anything.

1 Like

HI there!!

Last week I had the very exact problem, al the leds on the rio were good as well and everything looked all right, then we open the rio to see if there was anything inside and we found this:

IMG_1080 Small

Turns out we had some kind of rubbish inside the rio, we tried removing it but it didn’t worked right away, and then after the weekend fortunately it worked again.

Maybe your team scuttle something near the rio and some trash got inside of it. You should try opening and check if there’s something there.

Hope this helps and good luck with the rio

1 Like

I would advice against opening the rio, at least until NI say what they have to say

Opening your Rio to clean out swarf is perfectly fine, as long as you’re careful.


You may indeed have a failed chip … Even so I am yet to a see a failed Rio anywhere in our robots, and some of ours are from 2015.

It will not void your warranty. :slight_smile: Swarf in the Rio is one of the most common failure modes. They are remarkably reliable.

I opened the RIO in question to inspect for any debris, and to my surprise it was practically spotless inside (which I guess makes sense, this unit has lived as a test board almost exclusively, never been to a competition).

After 3 days of no response from NI, I called their support number only to be told that I made the wrong type of ticket, and was transferred to a different support line, who also told me they can’t help, and directed me to post on the forum.

No response yet, but the tech on the phone did say he would forward the link of my forum post on to someone he knew who helps with the FIRST-specific support issues. I will update again when I have a resolution.

What does the DS show for disk space usage? That error can sometimes show up if there is no disk space, which can also cause imaging failures.

Sorry for the delay, we had some time off between meetings. I followed NI’s advice and tried using last year’s (2022) version of the NI game tools with the same errors. Checking Driver Station shows that there is 0 MB of disk space available on the RIO, but I’m not sure how to remediate that problem since SSH/FTP are not working either.

SSH isn’t working? Thats odd, it shouldn’t be requiring disk space. What error is it giving? Make sure you’re usb connected when trying.

Worst case, you should be able to reimage after following these instructions. But it can be hard finding a USB flash drive that’s old enough to work.


Strictly speaking, you don’t need an old flash drive. Just one formatted correctly.


Rufus can format drives to settings that Windows won’t Rufus - Create bootable USB drives the easy way


This guy formats.