Defective Black Jaguars?

While working on updating the firmware of the jaguars and setting ID’s, we eventually discovered a very odd error. All the jags were successfully updated to version 92. We got a black jaguar last year, and in the summer, we got CAN working on it. This season, we have 2 KOP Black Jags and 2 other Black Jags, bought between the first one, and kickoff. All 4 of the newer ones cannot communicate with other Black jaguars (using serial bridge), and some of them (not sure) can’t communicate with any other jaguars at all. the old one can communicate with all grey jaguars, but none of the new black jaguars. So after 2 ish hours, we swapped all the black jags on our robot with grey jags, except the old jag and it worked.
Is it the jaguars are bad, or can we only have 1 black jaguar on a network, or is there a special way to wire it. we know the cables and ends are good, simply changing the positions as show below enables it to work

all grey and first black can communicate
laptop>good black>grey>black>grey>black>black>grey>black>terminator

reversing laptop and terminator ends, only directly connected black can
terminator-good black-grey-black-grey-black-black-grey-black-laptop

Make sure your cables are correct. Patchy connectivity throughout the bus is a symptom of cables that aren’t crimped pin 1 -> pin 1, pin 2 -> pin 2, etc.

To find a bad cable, try connecting each Jaguar one at a time. Start with your first Black Jag as the serial-to-CAN bridge and one additional Jaguar (Black or Grey). Make sure they each have unique IDs (not the same ID for both of them). Test all your cables between these two Jags to eliminate the bad ones.

The BDC-COMM application will help in these tests, so that you don’t have to run code on your robot. With each cable, test that you can control the second Jaguar (for example, change the voltage).

Now that you have checked all your cables, keep the two Jag setup, but now switch out the second Jag with another from your supply. Using BDC-COMM, make sure it is updated to version 92 firmware, and has a unique ID. In this manner, check all your Jaguars one at a time.

If you have even one set of duplicate IDs on the network, things stop working.

-David

We know it is not the cables, we were playing around with a bunch of them and they all work. It is also not the ID. connecting directly to any of the bad black jaguars works, its their communications in and out. signals pass through them when they are not the first on the bus.

My procedure from before is to help guarantee that it isn’t the cables or the ID. I know that on my teams robot, we can’t guarantee that a cable is good until we’ve tested it them in an environment where it is the only variable. Same goes for the IDs.

As a mentor, I know for a fact that the state of cables and Jaguars one night might not be the same the next night because there are some pretty eager students out there. All it takes is a student to think they have a problem, and the best solution is to reset the Jaguars to factory defaults (ID 1).

Can you move the Jaguars to different places in the network, leaving the cables in the same place. For example, try different combinations like this:

[Jag A (black)][Cable 1][Jag B (grey)][Cable 2][Jag C (grey)][Cable 3][Jag D (black]…

[Jag A (black)][Cable 1][Jag C (grey)][Cable 2][Jag D (black)][Cable 3][Jag B (grey)]…

[Jag D (black)][Cable 1][Jag B (grey)][Cable 2][Jag A (black)][Cable 3][Jag B (grey)]…

Does the failure move with the Jaguar or does it stay at the same place in the network? If the failure moves, this could help eliminate the cabling.

-David

From the information you’ve provided, it sounds like the Jaguars in suspect work, but just don’t support CAN.

Are ALL your black Jaguars like this?

Could you update their firmware again, and see if that changes anything?

We had an issue like that on 2 different black jags. We just flashed the firmware again and they worked fine

I know this is old, but I want to post my (odd) results.
When we re-flashed them, they worked fine, and I forgot about this for a while, until I flashed one again, and it did not work. After some testing I discovered this pattern:
Flash -> works
Re-Flash -> does not work
Re-Flash -> works
Re-Flash -> does not work
Re-Flash -> works
Re-Flash -> does not work
Re-Flash -> works
Re-Flash -> does not work
etc…

It appears that re-flashing a working Jaguar will fail, causing that Jaguar to not work. Maybe something to do with the bootloader.

If this pattern is the case for all jaguars, I would think that the manufacturer would want to know about this since it seems like a resolvable issue (even if the solution is just to release a notice to users about the existence of this phenomenon).