Digital Sidecar Problem

We are trying to use the photoelectric sensor as a encoder on our shooter, but we are getting no signal at all through the robot. The photoelectric sensor is connected to the PDB with a 20amp breaker and to the digital sidecar via the signal line on a pwm. We have tried changing the input used on the sidecar, tested the pwm, and even tried replacing the sidecar and DIO module on the cRIO to no avail. Eventually we tried simply replacing the sensor with a switch and found no signal returning to the DS! It was simply the default HIGH signal from the sidecar. We are testing using the default DIO “Simple Digital In” in FRC labview 2012 with the 8-slot cRIO imaged with the 2012 image.

you will want to use the “Digital I/O” slots on the Digital Sidecar - not the PWM slots

if you still have trouble - just respond again and we can help you get it figured out

Mark - Mentor from Team 1153

I am making sure to use the dio slots, any other ideas?

I am assuming that you are using the photoelectric sensor that came in the kit, although other will be very similiar.

If connecting it to the DIO does not help - then check your wires

This wire will get attached to the Power Distribution Board
Brown is positive - so connect it to a red power wire
Blue is negative - so connect it to a black power wire

Now check your PWM cable
take the black wire and connect it to the white wire on a PWM cable, and attach it to your DIO - you pick a slot

You can also check to see if the sensor is working because the light will change color, you can adjust the sensitivity by using a small screwdriver

Mentor mark

We found that one side of our sidecar ribbon cable had become unclipped, causing sporadic communications issues. A quick squeeze in the vise got it working like new again. Might want to check that?

There is a limit to how many ticks some sensors can resolve. It is possible that your wheel is running faster than the encoder can respond.

It is indeed



First thing we tried

The problem seems to be getting the input from the sidecar to the code, I will check the cable to the crio, we are using the new lightweight one.

It may spin to fast for the sensor, but even with a simple switch I am getting no input

Another strange error seems to be that our cRio never goes above 30% space free and seems to lag when first initializing. Perhaps a problem with the image? I know our new 4-slot works fine with about 50% empty after deployment. (And yes the 8-slot and the 4-slot have the same amount of memory space.) Our 8-slot also had to be repaired due to metal shaving last year, perhaps a problem from that?

How are you connecting the simple switch? How are you checking the input to see whether or not it’s working? We might be able to understand the situation better if you tell us the raw symptoms, and try to avoid diagnosing it.

No they don’t. The cRIO-FRCII has double the RAM and double the disk space compared to the cRIO-FRC.
This is what I mean by “basic switch” I also tried twisting the wire together.

I am using the example Simple Digital Input vi
Front Panel:

Also, I was told that the 4-slot and 8-slot had the same amount of memory, I was wrong. My bad

I checked the cable and the clips were fine. Thanks for the suggestions though

Or the cRIO FPGA can handle. ~39,000 ticks per second.

Which connections from the switch are going to what pins on the Digital Sidecar? What wires did you twist, and why?

I am using the example Simple Digital Input vi

What does it do when you run it? Does the Digital Input Value indicator light up, does it remain dark, does it change without an obvious reason, or what?