Direct Roborio-to-computer ethernet connection possible using 169.254.x.x?

Hi. We’re having a lot of trouble with our RoboRio. Our USB port does not appear to be compatible with the RoboRio.

Tomorrow when we go in for a second try at getting it to work, we’d like to know what equipment we need to have/buy in order to talk to the RoboRio over the ethernet cable.

Is the Robo Rio supposed to be able to work with a direct computer-to-RoboRio connection without a router offering up a DHCP address? (The manual says the device takes on a 169.254.x.x address, but doesn’t specifically state that this address is actually active on the ethernet port, or if its reserved for the USB ethernet connection.)

If yes, does the RoboRio require a crossover cable for a computer-to-RoboRio connection?


You do not need a router to connect to the roborio.

Just plug in and you should be able to use the roborio local address to locate it, assuming you have imaged it and set your team number.


Can you give more details and what you mean about it not working via USB?

Adding to what @Tom_Line said, you could also just use the robot radio. When set to AP mode (not configured for a competition, so it’s broadcasting wifi), it will give out DHCP addresses. So whether you’re connected over wifi or ethernet into the 2nd port on the radio (or through a switch), you should get a 10.TE AM.* address for both the roborio and your PC. But again, the roborio should still be accessible at the mDNS hostname mentioned above.

Adding to what @fletch1373 said, you can also plug directly into the roborio with ethernet. Look up the default IP range for the Roborio, and set your computer to static address on that range. Then you can use a port scanner to find the Roborio.

Sounds like they already have that range (it’s APIPA, so 169.254.x.y)

I would also recommend trying a different USB cable if you have not yet already done so. Is this for the Rio V2, or the original? I ask because if it is for the original, I think you will need the USB to format it (and regardless, you may need USB for Phoenix tuner if you need that).

There’s not much to tell. We tried two laptops running Windows 10, both with administrative access. We turned off windows firewall, plugged in the USB, held down reset until the RoboRio was in safe mode, then ran the imaging tool as an administrator and tried to flash the RoboRio. (It’s a version 1, not 2.) After a while, we get a notice on the bottom of the screen that say the RoboRio was being flashed, and then about 10 seconds later the software crashed with a list of instructions on what to try to make it better. (All the things we mentioned above.)

Another person used their computer (same USB cable, same RoboRio) and followed the same procedure, and it worked fine. It’s probably just some incompatibility with the USB port, it seems like other teams are having similar problem and the universal fix is to try another computer until you get one that works.

Windows in Safe mode ← did you turn on the Network Support? Without this, Windows does not boot with network stack support.

In general, a base Windows machine should be able to connect to the RoboRIO without any modifications. you shouldn’t need to disable the Windows Firewall - but you might if you have other vendors’ firewall/anti-malware/etc - especially if you allow the application access through the firewall when you run it first time after installation or during installation.

I would also recommended to set aside a ‘drive station’ only machine where only the latest firmware/util/NI/WPILIB are allowed to be installed. No casual use on that machine otherwise. This way you will always have a standard reference to fall back on.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.