Discourse Embedded Videos

I have noticed recently that embedded videos take forever to load. It takes easily 3-4 times longer for the videos to load than it does for them to play for me. The problem is not my internet connection, embedded youtube videos load properly. Any idea why this might be? Do other users have the same problem?

5 Likes

I’ve noticed it’s always had something to do with its size. That being said, even videos as small as 8mb sometimes take forever, so I doubt it’s only related to that.

It might be at the server end, CD delivering slower than YouTube.

1 Like

Can you link an example of a slow loading video?

At home, these videos will never load. On campus, forcing the video to download seems to speed them up.

Hmmmm…those videos work fine for me.

I think the videos might be cached locally once you load them. I’m going to videos that I know I waited 10 minutes for them to load and they’re loading in a reasonable time now. Next time someone posts a video I’ll link to it if it takes a long time to load.

Same issues.

Ah yep … I’m going to turn off mp4 hosting. That type of content better off on YouTube or Vimeo, or some other service that can handle it faster.

4 Likes

Looks like you can still upload and embed .mov files. (example here) Not sure if this is on purpose or not

That one is externally hosted. I just prevented them from being uploaded and hosted on the CD server.

Hmm…I guess some video files that are externally hosted show up with the same playback controls as the internally hosted videos. Never mind then