Do you have an NI-RIO connection in MAX?

When I connect to our cRIO using MAX, the NI-RIO connection shows an error (-60040). I’ve tried several different laptops and all show the same error.

NI-RIO server is running on the laptops with firewall disabled (I tried a static port first).

Is this by NI design or am I missing something?

Thank you,
David

I’m not sure where the error is showing up. Try looking up the error code using Help>>Explain Error. My installation doesn’t show the error code as registered, so I can’t offer much help.

Can you clarify where the error is showing up and under what circumstances?

Greg McKaskle

Greg,

Thanks for the reply. Unfortunately, there was a typo on the error code, it should be -63040, not -60040.

Here is a zip of two screenshots that show the situation.

David

attachments_2010_04_29.zip (329 KB)


attachments_2010_04_29.zip (329 KB)

I think error -63040 usually means there’s a networking problem. In addition to making sure there isn’t a firewall active, you need to disable all the network connections except the one that’s actually going to the cRIO. If you’re using wired Ethernet, that means turn off the wireless (we also had a FireWire network connection showing that had to be disabled).

Alan,

Yes, -63040 is a network connection problem - kRIOStatusRPCConnectionError. I have read all I could find on this error, and tried all the suggested fixes - both from NI’s site and the MAX help; and yet it persists.

Since even with this error I am able to deploy code and use the cRIO generally as intended (it runs the code, dashboard comm is good, ftp works), my question is this: Is this really an error, or is this just the way the system has been set up for FRC? When you connect to your cRIO thru MAX do you get the error too - or is it only me?

Thanks for your suggestion on disabling the wireless - I tried it right away, but without success.

David

I get the same error in MAX.
It might be because our FRC cRIO doesn’t provide traditional RIO device services.

Mark,

Thank you for checking. When certain features don’t work - (as they would on a standard system) - it’s hard to tell if it’s a problem or by FRC design.

Another example is Debugging a Stand-Alone Real-Time Application. I’ve never been able to get a connection to the cRIO to debug our code once it’s been deployed as a start-up application. The connection is refused on the cRIO side.

I can do this on a PC that’s set up as a Real-Time PC target, but not on the FRC cRIO. If this is by design also, (NI FRC support couldn’t tell me at the time), it would be helpful to have documentation about it so as not to waste time trying to troubleshoot it.

Have you been able to get the Web Server up on the cRIO?

David

This is probably due to one of the several services we removed to free up resources that were being used on the controller that are typically unused in the FRC environment. For FRC, we essentially ignore the existance of MAX… you should too. :wink:

We intended for this to work, but a bug crept in somewhere late in the game and we were unable to address it in time for Kickoff. I belive we intend to make it work for next year.

We had this installed and enabled on the controller during beta, but it was removed due to the resources it consumed. It was decided that there should be more available to the team code and libraries they might use. It did work well, though.

-Joe

I understand. Thank you Joe.

David