Does anyone have experience changing our output on the Talon srx from 5v to 3.3v?

Does anyone have experience changing our output on the Talon srx from 5v to 3.3v? We need a 3.3v output and are getting a 5v output through our talon srx.

Are you trying to use the Talon SRX motor output as a voltage regulator?

Can you provide more information (like a picture or diagram) for how you have it configured and wired?

Context

1 Like

From the Talon SRX user manual:


Looks like you just need to rewire your encoder to receive power from pin 1 instead of pin 2.

1 Like

I tried that. It doesn’t seem to work…

My 3.3-5v port on the lamprey2 will read 3.3 volts but the PWM is stuck at 2.1 and never changes… virtually there is a constant signal do when the encoder turns instead of a fluctuating one.

What about the analog pin?

1 Like

Im sorry, the analog pin is 0 (as in, it doesn’t output anything).

Have you gone thru the calibration described in the Lamprey manual?

Can you describe exactly how you tried wiring it?

Specifically the Lamprey 10 pin connector doesn’t appear to have a variable voltage input, but the two 4 pin connectors do.

Found the issue and a solution. You can’t change the srx output. The problem is with the Lamprey2 encoders we have. There is a batch of them that got new firmware in the last few weeks. It doesn’t allow the encoders to work at 3.3V and if you run 5V it creates this deadzone. Talked with the owner of the company, he ran some test, found the solution, is shipping me new encoders and showed me how to “hot wire” this on the board to get them going right now. We are installing our modules back on the robot and going to give it a try now but I know that we are getting a reading the full 360 degrees around now. They are fixing the bug on the ones they have and going to notify and few the ones at andymark as well. Sounds like the problem should be fix in the future because of this.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.