Does Driver Station work with Romi?

I see some mention in the wpilib docs that the real driver station can be used with Romi - but for me it’s not working.

My setup is as follows:
. Romi bridged on 192.168 wifi
. Romi ip hard coded in build.gradle
. Java example program for Romi
. Driver Station team set to 127.0.0.1
. Windows 10
. PC communicating over wifi

I can see the Romi web interface on wpilibpi.local. And I can use the DS-like controls in the glass-based simulation window. Also Shuffleboard works fine.

On the real Driver Station though what I get is:

Diagnostic tab: wifi green (whether or not the Romi sim is active), Robot green (only when the Romi sim is active), others unlit.
Operation tab: No Robot Communication.

And needless to the enable control, etc don’t work.

If there is a way to make this work, can someone clue me in? Or if it’s not doable, perhaps that could be clarified in the docs. (There is mention on the “Programming Romi with Labview” doc page that it should work, but I’m using Java, and there doesn’t seem to be any explicit mention other than on the Labview page.)

Did you enable “Sim Driverstation”

image

3 Likes

Now that’s an interesting question - I have seen that dialog before, but lately it doesn’t appear at all. I select ‘WPILib: Simulate Robot Code’ and it starts the build and launches, without offering that dialog.

I do have Desktop Support selected as true. And I found the setting ‘Change Default Selection of Simulations Extensions Setting’ was false - I changed it to true - but the Sim Extensions dialog still didn’t appear. Is there something else I may have misconfigured that’s causing the ‘pick extensions to run’ to not be offered?

EDIT: Solved! I found
"wpilib.skipSelectSimulateExtension": true
inside the settings.json file. Changing to false caused the sim extensions dialog to reappear, and then selecting simulate Driver Station works.

Thanks!

1 Like

You should also be able to change wpi.sim.addDriverstation() to wpi.sim.addDriverstation().defaultEnabled = true in your build.gradle to avoid having to select it each time.

1 Like

That’s a good tip, thanks.

BTW does anyone know - is it possible at all to have DS on a different computer from the one doing the sim, or it has to be coresident?

I’ve only gotten it to work on localhost or the roborio address.

I see that the DS does some mDNS queries, but seems to only connect to those two.

1 Like

I’ve not tested it, but you can plug in an IP address into the “team number” field in the DS and that might work. Note you’ll need all firewalls disabled on the simulation machine.

2 Likes