Downloading code: Netbeans does not reset cRIO

When downloading code, Netbeans stops at “Setting up for RUN”. When I reset the cRIO, the code then runs. In the past (before the official Java release, using Beta Java) Netbeans reset the cRIO for me. Additionally, I do not get a console to see the System.out.println’s of my program, as I did in the past, when Netbeans reset the cRIO and stayed attached to the connection.

Both my computer and the cRIO have been updated (cRIO is at v19 and the computer has had the latest “Labview” update). Does anyone know how to fix this so that downloading and viewing println output work correctly?


I’ve got the same problem on my personal laptop, although it works fine on the Classmate.
My laptop is running Ubuntu; I installed NetBeans and then used the plugin installer to get the FRC stuff. I also used the plugin installer to update NetBeans on the Classmate.

I was having the same problem. What worked here was to go to Network Connections and use the default computer IP ( in my case, in yours) to connect. After that try running the program again.

Hope this helps!

Can you ping the cRIO?

The issue may be that the broadcast UDP packet info may not be making it to your machine. If your on Windows, then try running the NetConsole for LabView. If it does not work, then neither will ours.

Make sure that your netmask is set correctly. We had this problem also, changing the netmask to the correct fixed it.

Hmm…that might explain it. My team has found that any computer with a static IP will download, while a computer using DHCP will not. This doesn’t make sense, unless you consider that the router suggests a subnet mask of rather than

I have the same issue. When I hit the build and run button my output line hangs on “set up for Run” It works when I reboot via the cRIO but I still want debug code. Any other ideas other than resetting the IP and checking the subnet mask?

Okay, so after great searching of forums and googling, I have finally found one solution to the setting up for run issue. It turns out the windows firewall seems to have been blocking communication back from the cRIO resulting in the disruption. So, if you have this issue and setting a static IP didn’t help, try turning off the windows firewall. It worked for us.

We are also seeing this issue, and we had to run a cable from the laptop to the router. I never had a issue before this build of squawk.