Downloading Firmware of REV Components

Our firmware of Power Distribution Hub and Rev Pneumatic Hub cannot be updated/download. We’ve tried multiple times with our USB-C connection, including power cycling. However, an unknow error ocurrs, as you can see below:


Then, if you click in Update:

After that, the connection stops, even with the USB-C linked.

Any suggestion of solutions?

I’ve had this same issue before, and the easiest way I’ve found to make it work is to leave the bot turned off, and plug the USB-C into only the component that needs to be updated. This way only the device that you are plugged into will show up in REV hardware client, as it will be powered by the USB-C cable.

2 Likes

Yep. We tried this way and the error still persists.

Have you tried going into recovery mode? Here are the links to the guide on how to do so.

PDH- Power Distribution Hub Troubleshooting - Power Distribution Hub

PH- Pneumatic Hub Troubleshooting - Pneumatic Hub

1 Like

Have you tried switching which usb port you are using on the laptop or switching to a different usb c cable?

2 Likes

Recommend this solution, works for most REV firmware issues.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.