downloading issue

Hi i can connect to the cRIO and “download” but i don’t think that it is downloading my program to the right place. when i right click the .out file and download it downloads it to the cRIO but everytime i restart the robot it deletes itself so i have come to the conclusion that i downloaded it to the RAM and thus is has a phyiscal memory dump every shutdown. can anyone fix this?

You are using Windriver correct? And using the FIRST->Download button?

Also, how do you know it is deleting your code?

Does it say “No Code”? If so, that could be a different error such as undefined symbols, AKA- A problem in your code.

i tried first download but it had the same effect.
when i rebooted i went into the driver station and it said “no code”.

oh and i was using the simple robot template and i didnt do anything to it.

Did you set up the FIRST downloader to work with your project? Go to Window->Preferences (I think) and click on FIRST downloader. Enter your team number and locate the .out file for your project.

Have you tried FTP to it? (10.xx.yy.1 Username:FRC Password:FRC, where xx is the first two digits of your team # and yy is the last two digits.)
It is supposed to be under the “ni-rt” directory and called “FRC_UserProgram.out”.

How do you do that? RAM (literally) can only be accessed by the computer itself…


It’s done with the Run/Debug (popcorn!) kernel task command in Windriver. WR sends it to the cRIO, which immediately loads it into memory, and runs it without saving it to a file.