Drive Station and Radio not connecting?!?!

Hello everybody, I’m on team 5145 WolfBotics. Our robot from this year: Q*bot, has been working great. He made it to the quarterfinals at the Orlando Regional and the finals at Roboticon Tampa Bay. I’m privileged enough to be his driver, so I have FIRST-hand (pun intended) experience with the FRC Drive Station. During both competitions, he worked like a charm. When practicing and between events, he worked. Now, after Roboticon, he is not connecting to our Drive Station.

Here’s what we’ve tried:

  • 2 other ethernet cables
  • resetting the radio
  • rebooting RoboRIO
  • restart computer (several times)
  • restart FRC Drive Station
  • restart Dashboard
  • let the computer sit for like 15 mins

We got him to work, but we had to disable him quickly due to sound of the pneumatics. If anybody knows what to do, it’d be very very appreciated! We need him for outreach and fundraising events, so he’s not done just yet.

A few quick tests: Can you connect over USB B? Over any connection method, try typing in the command line ‘ping roborio-5145-frc.local’ and see if you get a response. Other than that, try, on the computer, going to Control Panel\Network and Internet\Network Connections, right-click on your wifi card, and click “diagnose.”

  1. What are the Ethernet status lights on the RoboRio, are they blinking as if transmitting data, or off? If Off the connection is bad, if on/blinking, the cable is fine, and the issue is somewhere else.

  2. Is the issue over Ethernet, on wifi, or both?

  3. Ensure your radio was reprogrammed after your last event for AP mode.

  4. If still no comms, set everything to static IPs, teams should really be doing this everywhere, even at events, and not rely on Mdns

  5. Set Roborio to static IP using USB cable and webdash under network setting page. Set IP to 10.TE.AM.2, mask to 255.255.255.0, and default gateway to 10.TE.AM.1.

Note: If for some reason you can not get to web page over USB, after a few tries going to the http://172.22.11.2 in a browser, and investigating the lights on the RoboRio, you may need to reflash the Rio, but before you do that post back here.

  1. Set DS IPv4 to static IP. 10.TE.AM.9, with mask to 255.255.255.0, and default gateway to 10.TE.AM.1 (may need to restart or enable/disable the network interface after setting static ips)
  2. The radio will be at 10.TE.AM.1 after reprogramming

Using the Ping command in the console to trace the issue.
Ping 10.TE.AM.1 to see if you can see the radio
ping 10.TE.AM.2 to see if you can reach the roborio.

use the IPCONFIG command to verify your address settings are correct.

ensure your team number is set in the DS settings.
ensure your DS is set to use 2015 communication protocol.

Run the above sets on Ethernet first, and then on wifi over the radio.

If all else still fails, plug eithernet from RoboRio directly into DS and using static IPs, and verify comm port lights on Robotio are blinking. If this does work, the issue is network cables/hardware between RoboRio and Radio.

The LED lights on the Roborio are very useful on the Ethernet port as well as the lights down the side for troubleshooting. make sure the status light is also on, to ensure you don’t have dead code.

hope this helps, report your findings.

Dumb question: you had to configure your radio for Roboticon, correct? And you’ve reconfigured for home use, correct?

we have not reconfigured for home use. How do we do that?

Use the FRC Radio Configuration Utility 17.3 (2/14/17)

Programming your radio for home use

thank you all! We got it working!