Drive Station Not recognizing connection


#1

Our team has been working on a few off season projects and last night our drive station started acting very odd. We can connect the laptop to the radio and the computer shows a wireless connection. However, when we open the FRC dashboard, it never shows that we have a connection to the robot. We have tried 3 different radios and it does it for all 3, we have tried multiple computers, we have tried re-configuring the radios. I have tried everything I can think of and it just won’t work. If it is something that needs to be fixed in the network setting, I don’t know how to fix it. I am about to pull my hair out! Any help is greatly appreciated, thanks.


#2

Last time the students couldn’t connect, the problem was not yet changing the team number in the DS. The laptop had been updated, so that DS hadn’t been used yet.


#3

It sounds like you’ve done some great troubleshooting with the radio.

Since you mention the DS doesn’t have a connection to the robot, the next step would be to take a look at the roboRIO and the connection between the RIO and the radio.

Is there any activity on the lights on the RIO’s ethernet port? If not, is the ethernet cable seated properly?

Is the RIO configured properly? What do the lights on the RIO show?


#4

I have changed the settings in the DS to our team number 6055. On the RIO the the Power light is on and the RSL light is on, all others are off. On the radio, the power light is illuminated blue, the wifi light is illuminated orange and the light closest to the power is blue (the one with a W on it). The fourth light is off.


#5

Some questions:
• Can you ping the roborio? (type “ping roborio-TEAM-frc” in the command prompt, replacing TEAM with your team number)
• Can you load the webdash? (in Internet Explorer, go to “roborio-TEAM-frc.local”)
• Can you connect if you plug straight into the roborio, bypassing the radio?
• Can you connect if you plug into the roborio via USB B?


#6

The ethernet port on the RIO is green as well.


#7

I cannot ping the roborio.

I cannot load the webdash.

I cannot connect via ethernet by bypassing the radio.

I CAN connect via USB B to the roborio.


#8

Interesting. Just to be sure, did you have the WiFi network adapter disabled when connecting via ethernet and the LAN network adapter disabled when connecting over WiFi?

Do you have all firewalls disabled? (Windows 7 comes with 2 by default, Windows 10 comes with 3) Also disable all antivirus software, etc.


#9

I am working on the firewall settings right now as we speak. I am on a school computer so my IT guys scream at me for wanting to disable firewalls. I am allowing the DS app through the firewall but that still isn’t letting me connect to the robot. I guess my best option is to convince the IT guys to act against their own will and let me disable the firewalls completely.


#10

The best answer is really to have a completely separate computer for your driver station, that never touches the internet, and only connects wirelessly to the robot. Port software to it via USB sticks. Unless you’re doing vision processing or similar on your driver station, you really don’t need much horsepower; an atom-based computer like the classmate in the rookie kit is sufficient. When you need to connect the robot to an internet/LAN computer (e.g. to load software or do testing), use the USB cable.


#11

Another area that you could look is to make sure network configuration isn’t mixed. I’d check the webdash and then on DS to make sure it is good there.

https://s3.amazonaws.com/screensteps_live/images/Wpilib/262266/2/rendered/aea37f55-2860-4a37-912a-981d1e28d1cb.png


#12

Well the issue has been fixed. It was one of those situations that when you do enough troubleshooting steps, something was bound to work. I am not 100% what the fix was, but we were able to get it to connect with 3 different laptops. We even got it to deploy code wirelessly as well. Thank you for your help everyone.