Driver Station doesn't communicate with D-Link

We imaged our cRIO and configured our radio. The PC sees the radio, but the Driver Station doesn’t. Do I need to assign an IP address to the radio manually? I thought the configuration utility would take care of that. Please help!


Have you input your team number into the Driver Station app? There should be a box on the Setup tab with an XXYY in it. Change this to your team number and select the appropriate NIC to set up.

So the “bridge” light isn’t lighting up?
Technically, the Driver Station doesn’t really have to talk directly to the robot radio, as long as it can talk to the cRIO.
Is your PC IP setup correctly?

What does “see” mean here?

The “bridge” light on the DS panel doesn’t turn on. The internet was originally disabled on the PC I am working with. After I enabled internet connectivity, I wasn’t able to “communicate” (on the DS) with the cRIO.

To use the Internet you probably changed the PC’s IP to DHCP.
That would stop the PC from communicating with the rest of the robot network (bridge,cRIO).

The PC IP needs to be (wired) or (wireless) to act as a Driver Station.