driver station firmware update

Our team is having trouble uploading the firmware onto the Driver Station.

It seems that other teams have also had trouble, probably because of the wrong type of USB drive, but our problem is a little different.

The docs from FIRST say that we should use a usb drive that should not have auto-run programs on it… it would help if someone could clarify what that really means, because we have tried several different drives, some old, some new (from 128mb to 8gb). If the drive is the problem for us, then FIRST has done a poor job selecting hardware, since it’s firmware updates would be incompatible with most drives. I do not think that’s the problem though.

the file size we tried to load was about 2.2mb (it would have helped for first to clarify that rather than just say in the troubleshooting section to make sure it was the right size)… and the name we tried was dsud_pkg.bin, and that exactly. Different variations of capital letters were also tried, but I’m guessing that is not our problem either.

with the drive inserted (and no other devices connected to the DS) we plug the power cable into the DS and wait for it to load, then wait for the USB drive’s activity light to flicker (indicating that it has at least been accessed once). we then press the left (up arrow) and center (down arrow) buttons at the same time and hold them for at least 7 seconds…

Nothing changes. The DS does not recognize the command to enter firmware update.

we have no clue what is wrong here. could the DS possibly be defective?

I almost ripped my hair out.

Let me give you a first clue.

  1. THIS IS NOT A HOT PLUG USB DRIVE.

Did you figure it out yet?

Solution: Plug in your USB Drive before powering up the Driver Station!!!

Also you have to name everything lower caps.

This means that there are no other programs or files on the drive that open when you plug in the drive to a computer. I would say take a flash drive, copy everything off of it onto a computer, format it, place the firmware file on the drive, then plug it into the DS. See how that works for you.

Please note that if you are using windows and have the option turned on that hides file extensions, by naming the file “.bin”, you’ve really named it “.bin.bin” since windows is hiding the file extension.

Find this options in the folder you’re working in under tools -> folder options -> view -> hide extentions for known file types (should NOT have an X in it).

Also, by executable, they mean there should be nothing in the root directory of the USB drive except your file. Even better, just wipe the thumb-drive out and ONLY have that one file on it.

as I posted above, we plugged in the USB drive before powering up the DS (and tried a few times after powering up the DS, as the FIRST docs say to do). also (like I said above), most of the attempts to upload the firmware were with a version that was all in lower case, but the first docs seem to hint that case does not matter (since they say to use all caps in section 5.1, but use either all caps or all lower case in the troubleshooting section 3.1.9).

and no, I have not figured out the solution yet… my guess is that we have a defective DS, though (but I hope I’m wrong).

We tried formatting drives to fat32 and fat16 and that proved to be no help. There were no other partitions on the drives, and the .bin file was the only file on the drives. I’m guessing that FIRST intended to say that we should only have one partition on the drive and that any drive with U3 should be incompatible… because just about any USB drive has an auto-load function for a driver (if it’s hot-plug compatible on windows).

I’m not using windows… the file type used on all the drives we tested was exactly dsud_pkg.bin as I said. really, we just deleted all the extraneous parts of the name of the file when we downloaded it, which ends in dsud_pkg.bin

Ahhh… We’re not alone with this problem. 1st we couldn’t change the team number. We got help from here suggesting to up-grade the firmware. So we tried this option. Here’s what happens. Install the flash drive before start up. Connect power and allow to boot up. Held both buttons until told to release. Held “UP” unit told to release the same to the “Down”. Held the select and the screen flashes quickly and says this will take up to 3 min. The flash drive indicator flashes 3 times then the screen returns to the normal operating screen. With the “OTB” still on the bottom of the screen.

We can really use some advice as well.

I read on here there are only a few flash drives that a proven to work but can’t seem to find the post anymore. We also formated our flash drive and checked to see if we had the “.bin.bin” issue. We don’t.

we have yet to get that far… is there supposed to be any sort of response by the DS even if you have the incorrect USB device plugged in? In every attempt we’ve had, the DS looks unchanged when we hold the 2 buttons down.

Shouldn’t it enter the firmware update mode even if nothing’s plugged in and complain about errors on the screen if something’s wrong?

Here’s my two bits: (for Windows users only)
Make sure that Autorun.inf is either nonexistant or COMPLETELY BLANK. In the case of U3, it would point Windows to load the U3 software. If you have something like PortableApps on it, sometimes the autorun is set up to automatically load the launcher. Things like that.

Best bet is to delete the file and then eject the drive (without going through the "safely remove hardware interface/option) since Windows may try to stick the autorun back onto it.

Here’s my autorun.inf file, which is supposed to load the PortableApps launcher automatically on Vista.

[Autorun]
Open=StartPortableApps.exe
Action=Start PortableApps.com
Icon=StartPortableApps.exe
Label=PortableApps.com

Obviously this particular file won’t work on the DS.

This is not true, it will work just fine if you plug in the drive after the station has been powered up. I tried this several times myself, and examined the way the DS code performs the upgrade procedure.

The joysticks need to be plugged in before power is applied, but it does not matter for the USB drive.

The USB drive I have that I’ve tried several times is a Crucial Gizmo 1gb drive that has been reformatted with fat32 (I could reformat it again, but that seems superfluous). There is no U3 partition and there is no autorun.inf file on it (since I have not used it on a windows machine since reformatting it). The only file on it is the .bin file.

The DS is totally unresponsive to the button sequence. I’m wondering if that’s been the normal outcome for you guys when using an incorrect drive or whether it should enter into the firmware update and then complain that the USB drive is incorrect.

Your best bet is to grab one of those 128 MB or 256 MB freebies that you get at trade show, or go and get the cheapest smallest flash drive you can find.
Maybe ask you sponsors if they have any of those.

Alright, we got the update to work… we just had to get a second DS cuz our first one was fried.

be sure that ur flashdisk has no auto run files :smiley:
if ur flashdisk has an auto run file … it will not work on ur DS

Make sure your jumper cable from the bench top tests is unplugged. :smiley:

My team is trying to set the new driver station update but we are not able to updated and we have try using different USB drives and we have not been able to do it, by some of the post that we read they said that we need to plug the USB first and then put power to the driver station but it does not work. We are trying to put the 2009-02-010a3 can some one help us :smiley:

I’m not sure if it will change anything, but I recommend unplugging all other usb devices and plugging in your flash drive to usb slot one on the ds. As mentioned above, it does need to be plugged in before startup.