Driver Station in Parallels?

Hi all,

Last night I spent about 45 minutes trying to get Driver Station working with the robot in Windows 8 through Parallels on my Mac before giving up to do something more productive. I’m not intending that this be used at competition or anything, it would just be a little more convenient in the shop to not have to use a separate driver station computer.

I figure there has to be an actual way to make this work (but maybe not).

Here’s what I saw and tried:

  • Connected wirelessly to robot bridge
  • OSX WiFi IP was a static 10.16.75.67
  • Was able to deploy code, ping 10.16.75.1 and ping 10.16.75.2
  • In parallels, before setting static IP, I was able to ping 10.16.75.1 and 10.16.75.2. I was connected through the “Ethernet” connection which is the network adapter shown in the VM. All 3 lights red on DS.
  • I did ipconfig and realized my IP on Parallels was DHCP. I changed it manually to 10.16.75.68.
  • I was no longer able to ping 10.16.75.1, 10.16.75.2, or 10.16.75.67. All 3 lights red on DS (can’t communicate anyway).
  • For fun, I tried changing the static IP in Parallels to 10.16.75.5 like an official driver station as I couldn’t remember if only .5 may connect with DS or not. Same symptoms (not able to ping .1, .2, or .67)

If anyone has successfully used DS through Parallels or can see what I’m doing wrong (or just has an explanation of why it doesn’t work, might just be because of the nature of Parallels?) tips would be greaty appreciated.

Thanks!

Edit: After searching (I didn’t search first, whoopsie), it has come to my attention that DS should work perfectly fine in parallels. I will try hardwiring tonight instead of wireless and see if that makes a difference.

Also, I always set my subnet mask to 255.0.0.0