Driver Station issues - Joystick sometimes doesn't repond

Hello everyone,
We’re having problems with our Driver Station. It seems it can’t recgonize USB drives which are entered to it, neither the Joystick nor the Disk-on-Key we used to reupdate the firmware.
Sometimes it does work for a short while, but then it dies again.
It once worked perfectly, and it died later on in the project.

Can you please help?
Thanks in advance, Dor.

Are you plugging it in after it is already on? Because that won’t work. Whenever you swap in or out the USB devices, the DS must be restarted.

Does it do this with all 4 ports, or just 1? Try the joystick in all the ports to see if it still dies.

We are connecting it when it’s off. We tried all the ports. We tries both sticks…
We did manage to use the joysticks for a while, but after we turned it off, they didn’t work again.
We think it’s a problem with the DS USB connectors, because everything works well, except the Joysticks.

Thanks for the help.

I notice you’re one of the israeli teams, so I presume you’re operating on 220V/50Hz power. The power adapter we were given in the kit (here in the US) is a 12V, 1000mA adapter rated for 120V/60Hz power. If you’re using this adapter, it would be putting out significantly more voltage, in the 20V range, which might be cause the problem. Or, if you’re using a different adapter, you should make sure that it’s rated for a 12V, 1000mA output. If your adapter isn’t putting out the correct power, it could be affecting the operation of your USB devices, which need a certain amount of 5V power to operate. This is more likely to be a problem if your adapter is putting out too low a voltage, but you should still check to make sure you’re powering the DS properly.

We use a second adapter to change from 220V to 110V and connect the original adapter to it.
You think that if the power is not right, everything will work except the USB?
I’ll see if we can find a different adapter.

Thanks for the help.

Well, the thing is, there are no other problems (or are there?) with the driver station. there is communication between it and the cRIO, the programs work on it like they should, only the USB drives usually doesn’t work.
like Ori here said, we’ll try to get our hands on another adapter, and try to do that.