Driver Station issues

Are there any known issues with version 18.0.1 of the Driver Station software? We are having a weird communication issue and it’s beginning to point to the DS. The robot will boot up and the DS will say comms are good, along with working robot code. The roboRIO has a green comm light. The camera feed shows up on the SmartDashboard. However, seconds later the DS says there are no comms or robot code. The rio says comms are good. The SmartDashboard still has live camera feed.

This points to a DS issue, and I’d like to know if there are any known issues.

Does this happen when you enable your robot? If so, you may have an infinite loop somewhere/your code might be crashing.

First thing I’d check is to make sure that all firewalls (private, public, domain) are turned off on the DS laptop. Strange things can happen if they aren’t.

This happens when it’s disabled. There were two instances when comms stayed and we enabled and moved it around a little. Soon after we disabled it lost comms, though. There was nothing in disabledPeriodic().

All firewall protections are disabled, along with antivirus.

Finger Lakes Regional CSA here. I had a team experiencing similar symptoms. We seemed to have it tracked down to an issue with the Rio (NI_Comms or kernel-level USB driver crash). It only seemed to happen when USB camera(s) were connected.

When the loss of comms occurs, are you able to ping the roborio (via mDNS name OR IP address)?

What’s your RoboRio firmware (not image) version? Should be something like “5.0.0”. The team I was helping noticed significant improvement after updating from “3.0.0”, which is a few years out of date (but perfectly legal for competition).

Have you tried a different DS computer? I’m willing to bet it will still occur with another. If so, it’s definitely not a DS issue, as was the case with the team at FLR.

Have you tried reproducing over USB vs Ethernet connections between the DS and Rio? If using Ethernet, do you go direct, or have the radio (or other switch) in between?

What roboRIO image are you using? Your symptoms sounds similar to what was fixed in v17.

I overlooked this in my previous comment. There is a known (and resolved) issue with Java teams and Rio image v16. v17 fixes it, and is available via the 18.0.1 update, which you already have installed if that’s your DS version. Please verify your Rio image is v17 before attempting any troubleshooting steps in my previous comment.

Also, in reference to my previous comment, here is the thread where a couple others have described similar symptoms with Rio image v17. You’ll find a rather long comment by me describing the various troubleshooting steps I attempted.

The rio was v17. We used the last of our unbag time today, so all of this testing will be done on Thursday starting 5pm. I can’t remember everything, but I’ll do my best.

We replaced the rio today. The old one was v17 and the “latest” firmware version. We tried a different laptop but it still didn’t work. We did stuff with the web interface, re-imaging, and SSH, but none of it worked. We tried directly plugging into the rio with ethernet but it still didn’t work.

The weird thing is we randomly tried laptop->ethernet->radio->ethernet->rio everything worked great. I didn’t try wireless. We were able to deploy code and even do some testing. Before we switched to the ethernet+radio setup, I removed some camera code that we thought could have been causing issues. Between competitions, I upgraded the camera code so we would have higher resolution. I copied the code from team 7160. I didn’t know really what numbers to change, so I set the width to 4000 and height to 3000. I know those are ridiculously large numbers, but I figured the rio would take care of taking the numbers down to something realistic. I don’t know if it ever did.

When I made this camera code change, I experimented with a different roborio. We have a “practice bot”. It’s just a board with almost all of electrical components of the real robot with talons, solenoids, etc. I deployed the code to it and it worked great. Not a single issue. The code that I deployed to it was the same code deployed to the real robot.

Anyway, I deployed the simple camera version to the roborio immediately after switching to ethernet+radio. And after that, the communication was solid. Not a single issue. Code deploys worked and I was even able to do some testing with motors. I do not know if this was due to the camera change or the setup change. However, Fletch1373 makes it sound like there could be something to do with the setup. I haven’t had a chance to read everything yet, but I’ll get to it soon.

Edit: Forgot to answer some of the other questions. When I pinged via USB, random amounts of packets would be lost. We’ve tried several laptops.

And I just remembered! In addition to simplifying the camera code, I ALSO just unplugged the camera. So that’s three variables that were never individually tested. However, it isn’t consistent. Wouldn’t it also not work on our practice bot? The practice bot works fine.