Driver Station long error

My code compiles but when in the driver station i get this long error message that no one understands.

ERROR Unhandled exception instantiating robot org.usfirst.frc.team5473.robot.Robot java.lang.RuntimeException: Code: -1029. HAL: Resource already allocated at [edu.wpi.first.wpilibj.hal.PWMJNI.allocatePWMChannel(Native Method), edu.wpi.first.wpilibj.PWM.initPWM(, edu.wpi.first.wpilibj.PWM.<init>(, edu.wpi.first.wpilibj.SafePWM.<init>(, edu.wpi.first.wpilibj.Talon.<init>(, edu.wpi.first.wpilibj.RobotDrive.<init>(, org.usfirst.frc.team5473.robot.Robot.<init>(, sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method), sun.reflect.NativeConstructorAccessorImpl.newInstance(, sun.reflect.DelegatingConstructorAccessorImpl.newInstance(, java.lang.reflect.Constructor.newInstance(, java.lang.Class.newInstance(, edu.wpi.first.wpilibj.RobotBase.main(]

please help. need solution asap.

The stack trace (error output) indicates that you have a problem at line 46 in your code.

The error message indicates that you tried to use the same PWM port in the construction of more than one SpeedController or Servo.

Read through your code very thoroughly, odds are you declared something incorrectly or you put something in the wrong spot. I could try and help if you post code

There’s your error!!
Any time you get a ridiculously long error message (I’ve been getting several of these over the past few days as we restructure some code), look through it to identify any java file YOU wrote…i.e. The other .java files are from the wpilib, and can help you see what element of the code is causing the problem. Also, the shows that the error (as mentioned by someone earlier) is at line 46.
Open up Eclipse (or whatever development environment you’re using), and scroll down to line 46 in your file.
There may not be any explicit errors, so you’ll have to look at what exactly is written there. Chances are, it’s a problem with a class from the wpilib that you’re calling for the first time, and from the rest of the error message, it looks like potentially a Talon/PWM port issue.
Check to see where you declare the port that your PWM plugs into (usually declared in the RobotMap, or at the top of a class), and make sure there’s no duplicates (i.e. Talon 1 is being assigned to port 0, and Talon 2 is also being assigned to port 0). This may not be obvious, especially if you’ve redone your code a few times, or physically moved things around. Also, make sure to look at the physical robot, and where everything is plugged into the RoboRIO. Make sure that the assigned port in the code matches the port that it is physically plugged into on the RoboRIO.
If everything lines up and you’re still getting an error, post some code and we can try to help you out!!

Thanks, guys, works now.