Driver Station not picking up PSoC

So we just got the PSoC FirstTouch 3 and I formatted it with FRC_IO.v2.hex as instructed here. However, when I start up the driver station (v02.27.11.00), it doesn’t pick it up. Meaning that the I/O LED doesn’t turn green.
Any ideas?
UPDATE
We have nothing hooked up to the PSoC except the eStop Cypress Carrier.

You need to make sure that you didn’t update the Cypress programmer software. If you did, it upgraded the USB code to a new version from Cypress instead of the custom version that allows the DS to talk to the PSoC. If you did update the Cypress programmer software, uninstall it and the Driver Station update, then reinstall the Driver Station update.

-Joe

Cypress version check:

  • Driver Station Install = 3.12.0.827 (correct version
    ) - Update from Online = 3.12.4 or greater (user did an online update - incorrect
    )*]Cypress DVD case = 3.10.0.440 (user installed the Cypress DVD – incorrect)
    Start PSoC Programmer, then go to Help -> About PSoC Programmer

Another quirk we found was to do the following:

Run the Driver Station.
Unplug the PSOC-3 from USB.
Replug the PSOC-3 back into the USB.
Wait a minute or so.

You should then get a message(s) that drivers are being installed.
The PSOC-3 should then become available, and should work hereafter.

I uninstalled PSoC Programmer, ran the driver station update, and flashed it with the hex file. I’m still not getting any response. If it helps, the PSoC Programmer says that it is FirstTouch3 version 1.15

Look in Control Panel -> Administrative Tools -> Services
to see if there is a service running called: CyMiniProg3Service
If it’s there, what status is listed?

Status is set to Manual and isn’t started atm

If the service isn’t running then the device in Device Manager will stay as unconfigured and will not be detected by the Driver Station.

Ok, so I turned it to Automatic, started the service, and plugged in the PSoC.
It’s still not being picked up by my desktop. However, I did bring the team netbook home, and the driver station is picking it up on there. What is wrong with my computer then?

Compare the ftk_3_simfw.hex file on the 2 machines and make sure that they are identical.