DriverStation issues, Rio or Radio? - Help

Hi, our team is having an issue with our connection to the robot, it is fully functional over the cable to the RIO (code deploys, can run autos and teleop, appears, ectara) BUT when we use a radio it shows up yet does nothing in DS. The network appears, the lights are on on the Ethernet port on the RIO, we updated our software and our radio was just formatted and such (for the 3rd time). We have updated the team number on the RIO and we have tried POE and the barrel connector to the radio. We have tested the radio separately and it is fully functional. What could the issue be with the RIO that is causing the failure to function over radio and what are some possible troublshooting options that we have not used? We have tested two different RIO2’s and they spit up very similar errors.

Warning  44004  FRC: The Driver Station has lost communication with the robot.  Driver Station 
Warning  44002  Ping Results: link-bad, DS radio(.4)-bad, robot radio(.1)-GOOD, roboRIO(.2)-bad, FMS-bad Driver Station

We have no idea how to interpret this warning and we couldn’t find how to troubleshoot this anywhere.

ALSO - we have tried several ethernet cables and it doesn’t change anything

1 Like

Here is a link to our code:

Is the firewall disabled on the DS? I’m only asking because it wasn’t mentioned above.

The firewall is disabled on the computer. I just double checked using the WPILib steps Windows Firewall Configuration — FIRST Robotics Competition documentation

Looking at driver station Diagnostics tab, there is a green light next to FIREWALL, but I"m not sure is that is supposed to be on or off?

Sounds like that is fine then. When you say “over the cable to the RIO” was that USB or ethernet?

Problem seems to be solved now. We replaced an ethernet cable and reconfigured the radio. Keeping an eye on it though.

1 Like