DS always disabled

We can never get our Driver Station out of the disabled mode.

Here is our setup:

Driver Station (eth1) connected to cRIO via crossover cable.
The driver station has software 2008_10_29a (most recent from WPIlib site).
The cRio has image 2009 v7 (most recent).
USB port 1 and 2 are connected to the kit joysticks
The competition dongle is connected in the enabled (down) position.
The DS is in tele-operated mode.

We turn on the DS and wait for it to boot. The screen indicates “Battery: N/A”.
We turn on the cRIO. The DS briefly displays “Battery: No Code” then “Battery: 00.00V”.

We connect the jumper in analog bumper 1, but even when we do this value is inaccurate, jumping around in the sub-1 volt range) We don’t care about this issue too much at the moment, though it might be a related symptom.

The DS displays “Mode:disabled” and we are not able to get it to be enabled.

We have successfully built the sample code and we can upload it to the cRIO without any chance in symptoms.

The IPs of both the DS and the cRIO are verified to be correct. Our DS has the team number correct as well. There is indeed some communication going on as evident by the battery voltage status and ethernet activity.

I have looked throughout the forum and have not found problems relating to “stuck in disabled mode”. We have had problems with this DS before (bum flash update). We sent it in and they told us there was a cold solder joint. They fixed it and gave us the board back, but we are suspecting that there might be something else wrong with it. Before going down that path, I’d like to make sure that we aren’t missing anything.

(I don’t have the equipment in front of me, so my display messages might not be 100% accurate)

Thank you very much.

First, check your dongle. A broken wire or faulty switch will prevent you from enabling the system. Chapter 3 of the Control System manual says the switch is connected between pins 8 and 9 of the DB-9 connector.

Thanks for your reply, Alan.

I knew I forgot to mention something! We had tried shorting out pins 8 and 9 to no avail.

If it helps in your diagnosing…
The “enabled” / “disabled” message on the DS screen is unaffected by any other part of the system.
You don’t need to power anything, other than the DS itself, to test if the dongle is working.

If directly connecting pin 8 to pin 9 didn’t earn you the “enabled” message, then that’s a DS hardware failure.

The only thing you have control over that could possibly affect it is the DS firmware upgrade.

Although it wont help you, as you have probably tried both switch positions, but the “enabled” position on the toggle should be up, not down.

Mark, that helps tremendously. Thanks! We have flashed the DS twice with the firmware… We’ll be contacting the KwikByte support.

Tanis, we opened the switch and probably mounted it back in backwards without realizing heh.

We are having the same issue. Any luck contacting Kwik Byte? Any solutions offered?

We have the latest driver stations update (2009_01_22c1) as well as NI Update 3a.

When we turn on our Driver Station without anything elase other than power and the enable/disable switch, we can change from disabled to enabled.
When we add in the PC’s ethernet, it still works.
When we connect either the cRIO via ethernet or connect the router via eithernet the DS will not exit disabled mode.

I think it is the new update. Both of ours were fine before the update, now they both lock in"disabled" whenever we are connected to the cRIO. Does anybody have a copy of update 2? at least that one worked.

I’ve seen this when the cRIO was at Update 2 and hadn’t had Update 3a installed.
Restoring to the Oct DS firmware release does work, but reimaging the cRIO should work.

Also, For some reason, If you remove the watchdog, the Dongle switch for the DS does not work. When the code for the watchdog is added again, it functions normally… Strange.

I’ll have to try that one. That’s good to know. Thanks.