DS broken???

we were programing our robot then all of the sudden it would not connect then we re-imaged it and it would still not work. When we tried to to re-install the update it would not even go past the KwikByte screen.

If the Driver Station can’t get past the KwikByte screen, then the unit probably needs to be re-flashed.
That takes special equipment a nearby team might already have, or you’d have to send it to KwikByte for re-flashing.

Is your Driver Station grounded as per: http://www.usfirst.org/uploadedFiles/Driver%20Station%20ESD%20Sensitivity%20Rework%20Instructions.pdf

Yes it was grounded, only thing was that we had some switches on the AI’s that didn’t do anything.
However, the DS is more than not responding, it sucks up all data that goes directly to it, and only acts as a tunnel. If anything that requires DS input runs, it picks a random value and carries it on to the rest of the program (LabVIEW last update)
Is it possible that we have leeched all the data out?
BTW the usb’s work, I am charging my phone on it right now.

I’m not sure what you mean.
See if I got any of this right…

Does your DS LCD screen display what it’s supposed to?
If so, tell us what it says.

Can your PC communicate with the cRIO while connected through the DS?
ping, FRC Imaging tool, LabVIEW Run, ftp,…anything?

Does a program running on the cRIO receive incorrect random joystick values?
How do you know? Dashboard, runaway motors,…?

the drivers station says only one thing “KwikByte” it never changes and never fluctuates.

the computer can communicate with the cRio through the DS, LabView rum works, imaging tool seems to work (its hard to tell), the only thing that does not work is any thing relating to the camera.

and we made a program that pulls data from every resource and and displays it but it ether displays it all at the extreme, with nothing happening or with no data at all and still nothing happening.

It sounds like your core problem is the DS needs to be re-flashed.
There’s no time to send away before your first regional this weekend, but scattered teams, and possibly the Spare Parts desk, have Do-It-Yourself kits, so someone attending your Regional can probably do it for you for free.
For future reference:

Your cRIO won’t operate fully unless the DS is doing it’s part, so it’s not too surprising that your data displays are default values or random floating values.

Meanwhile, you might try Dave Flowerday’s PC replacement for the Driver Station.
That might keep you programming and testing until the Driver Station gets fixed or replaced.

We have been trying to reflash it, since Wilsonville loaned us an extra they had, but we cannot communicate with the DS at all. Is there still the possibility that it has a leech virus in it?

No, your Driver Station does not have a virus.

Are you talking about updating your broken DS with a memory stick or reflashing with a PC and custom serial cable?

Does your robot work with the Wilsonville DS?

we are trying to re-flash it with a serial cable and adapter that we got at Radio Shack.

Yes, our robot works with Wilsonville’s DS.