DS NO ROBOT CODE ERROR

After we got the system home from the comp, we turned on the robot and were unable to get a response from the DS because of a “NO ROBOT CODE” error, I have tried all the steps I have read in the forms, and nothing seems to work. The cRIO is working correctly because I am able to trigger the DIO to high and low states while deploying the code in LabVIEW. I have formatted the cRIO, reloaded the image and have full connectivity within the DS. But still I have the same error…

What should I do???

:ahh:

Did you remove the encryption from the bridge?

  1. What is your Robot Signal Light doing when you boot normally?
  2. Are you deploying code to the cRIO and not just running the code with Labview’s run button?
  3. Has a mischievous gremlin switched the No App DIP switch on your cRIO? (Sorry, don’t recall how the correct position looks)

EDIT: See page 12+ of this document for DIP switch settings:
http://decibel.ni.com/content/docs/DOC-2632
Make sure Safe Mode, No App, IP Reset, and No FPGA are all OFF.

I am directly connected to the cRIO from the Classmate.
All the DIP switches are in the correct position
I am able to deploy the Digital IO vi and get the 0 to 5V change when changing the Boolean value.

I am working on just trying to get the teleop to work without the DS software in LabVIEW.

I’m confused by this “deploying Digital IO.vi”. Are you hitting the run button from Labview for all these things, or are you Deploying your project from the Project Explorer? I just want to make sure we’re all clear that the hitting Labview’s run button doesn’t save code on the cRIO. The only way to save code on the cRIO is to Deploy a project from the Project Explorer. If you’re already aware of this then apologies for insulting your competence, just making sure we’ve got the basics covered.

That said, have you tried creating a fresh project and deploying that? That should take care of any oddities in your current code causing problems. Also, are you getting any diagnostic errors on the DS?

Kevin,

I have done those steps first, and now I have been working on just getting a real-time response.

Things I have done.

  1. Built and “Run as Startup” for Default Project
  2. Formatted and re-imaged cRIO multiple times
  3. All DIP switches on in correct position
  4. Reset IP on cRIO and set it back to what is is suppose to be.
  5. Computer IP address on DS is correct and connected to the cRIO directly via CAT5.

If directly connected, are you using a crossover cable?

As I understand it, you can read sensors without the DS, but to have actuators active, the DS is required to be running.

I don’t understand. I’m pretty sure you’re not trying to run without the Driver Station, but that’s what it looks like you just said. Something about your descriptions of the problem doesn’t match what I’ve come to expect as the typical vocabulary when talking about the control system.

You’ve answered only one and a half of the direct questions posed to you. It’s not easy for us to help you unless you help us to do so. Here’s another question: Did you choose “Run as Startup” after you reimaged the cRIO? Your list of things you have done is in a very unconventional order, and if you indeed did things that way, you would have erased the code immediately after loading it onto the cRIO.

Ok,

system=robot

I had no problem with the system working correctly at the Bayou Regional.

Once the system came back to the H.S. that I mentor it was discovered that when the robot was turned on and hooked via a patch CAT5 cable, instead of wireless the robot did not respond to any DS input or could not be enabled in any mode (auto/tele/practice) because the “No Robot Code” light in the Dashboard was not green.

I have always built the code, then deployed it as “Run as Startup”
This worked all through competition season till after the Bayou Regional once the robot was returned.

With the robot on, and the DS running I have a green communication light,

The error that is given to this day is as follows:
THIS IS THE ERROR FROM THE OPERATION TAB IN THE DS DASHBOARD WITH THE MOUSE ON THE ROBOT CODE INDICATOR
There is no user code running on the robot

  1. If developing code use the tools to start it.
  2. If ready for competition, build and deploy it as a startup application

THIS IS THE ERROR FROM THE DIAGNOSTICS TAB IN THE DS DASHBOARD
No change to Network Configuration: “Local Area Connection”
I/O unit not detected or not installed correctly.

The LED on the Digital Side Car the light is blinking slow, which means the system is disabled.

I have made a 32-pin test connector for the slot 6 DIO. On this connector I have an array of LEDs. I have determined that the digital sidecar DIO14 correspondes to pin 3 and have added code in the Begin.vi for the LED on pin 3 to light up once the code runs. You may say…“Well why not use the digital sidecar to light the LED…” I wanted to come directly from the cRIO to minimize other possible variables…

I do have a digital sidecar connected to slot 4.

So with the code deployed as “Run as Startup” and the DS software running, the Digital Sidecar in slot 4 has a status light blinking slow, and my test adapter has the LED on pin 3 which is DIO14 lit, which indicates that my code is running on the cRIO.

To test the real-time connectivity from the Classmate to the cRIO while a program is running in LabVIEW, I used my test connector on the slot 6 DIO and the example for a digital output to activate and deactivate the LED on pin 3. This worked successfully.

I am trying now to figure out where the DS DASHBOARD code is so I can set the Boolean value for the “Robot Code” to true and see if this fixes my problem.

Have I stated my situation clear enough??

Thanks

So, when I fully describe the problem…then no one wants to help with anything I might be missing? I am still stuck and need help to get it running.

Your description is hard to follow. I’m having a difficult time determining the sequence of events that you went through.

Let’s start at the beginning. On the Diagnostics Tab of the Driver Station application, what is it reporting as the DS Version and cRIO image?

My suggestion is to connect things together tethered as you describe. Provided you have Communications and No Code, open the source VI, Robot Main.vi and push the run button. If that works redo the build and deploy and ensure it is set to run as startup.

If the cRIO was reformatted, the deployed app was erased. That would explain what I get from the description.

Greg McKaskle

Guys,

Thanks for all the help!! I figured out why I was having the problem.

I was installing both of the updates, being the DS update and the Labview update on the Classmate. After installing the DS, I am pretty sure installing the Labview update which is meant for computers other than the DS, it corrupted some files that messed up the communication protocol between the cRIO and DS software.

So everything is now up and running just fine!!!

Thanks again for all your help!!!
-Christopher