DS not owrking

We have been playing with the new electronics for close to a day in total hours, and it still will not work. Today, we finally got the CRIO to take image version 7. The DS has the latest image also. However, THEY STILL WON’T TALK TO EACH OTHER!!! (sorry, but it is really starting to annoy me.) I don’t think the CRIO is having the issues here, though. The DS said no Comms until I pluged a computer into its second port with the IP of, and then it gave a battery reading of 0. I got a packet sniffer (Wireshark) that is recomended by NI to see the communication between their RIO’s and the computer. The DS was brodcasting the message “Who has Tell” It stopped when I plugged the computer in and started showing the battery as 0 volts. What are we doing wrong?

Did you set the ip address for the DS and the CRio?

Check out these:

When you reimage the two devices you need to set the ip addresses as per the manual…

We tried setting all IP’s a second time. They are correct. I just find it odd that the DS was looking for the IP of a laptop instead of the IP of the CRIO. Has there been an update for the DS reciently that we didn’t get? One of the first things we did when we go this was update the DS (before we even tried to test it. It has not worked yet).

Did you try using the wireless switch/router and the bridge insted of the cable to the laptop? Try connecting it with those and don’t include the laptop at all… let me know how it goes…

Now we are getting somewhere.

The DS should not be updated until instructed to do so in the manual. If it is done out of order, it won’t communicate. So, now the question is, what else needs to be updated? I’m guessing you might as well update the LV software with update number 2, and re-image the cRio with the newest image. Then, set the addresses and all should be well.

Bottom line, it sounds like the directions in the manual were not followed, correct?

I didn’t even think of that yes the manual states i beieve that the DS needs to be updated before the cRio. In addition the cRio needs to be uptaded through the DS

Laptop —> DS —> cRio

hope it helps…

We updated the DS because we couldn’t get the benchtop test to work. We thought we might have to update it and set the team number to get it to work. It was only after we did that that we discovered the Digital side cars need their own power and don’t get it through the giant cable. The CRIO was updated through a crossover cable, but other teams said that had success that way. Do you think we should try the update again through the DS? Also, what version of firmware do yu guys have on the CRIO? We found something labeled version 7, but everyone else seems to have version 2.

I’m not sure where a version 7 would come from.
Get the version 2 update from here. It will update LabVIEW and allow the cRio Imaging tool to update the cRio to the latest version as well.

In the FRC cRIO Imaging Tool you should be loading the FRC_2009_V7.zip
In comes with Update 2.

…_V2.zip is from Update 1.

Thanks guys. I think it is working now. It started acting communicating properly. I don’t know what we did differently. It just started working? Now, if we can only get my code to compile so we can test it…