Eclipse C++ not working and PATH error

I decided to go ahead and start the robot coding in C++.

I now notice two things, nothing is working and many things, including stuff in files already made are saying “___ could not be resolved”
By __ I mean type, symbol etc…

I also noticed that when I build, I get this message:

Cannot run program “arm-frc-linux-gnueabi-g++”: Launching failed

Error: Program “arm-frc-linux-gnueabi-g++” not found in PATH

I have dealt with PATH problems before but I can’t find any file or folder like this and I feel like this may be the cause of my problems.

Please Help! Thanks!

Have you installed the C++ toolchains and set up Eclipse following the directions on ScreenSteps (

Yea I have, I’ll try uninstalling and installing eclipse again though

Yea that didn’t do anything…

Did the messages that said things like:

Cannot run program "arm-frc-linux-gnueabi-g++": Launching failed
Error: Program "arm-frc-linux-gnueabi-g++" not found in PATH

go away after you reinstalled the toolchains?

Could you try running this command to see if the compilers are on the PATH:

arm-frc-linux-gnueabi-g++ --version

You should see something like this:

arm-frc-linux-gnueabi-g++ (GCC for FRC) 5.5.0
Copyright (C) 2015 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO

Hi, which files is/are the toolchain? I don’t want to delete something I shouldn’t since I have a bunch of FRC-related files

For my team we had a similar issue. The way we fixed it is by adding all the bins under C:/frc, I think there are two, to the system environment path. Obviously it’s preferable to put it in a script and not permanently change your path, but it’ll work fine that way. That’s where arm-… is.

Do you know if this will fix the errors I mentioned. Multiple things are highlighted red and say “not defined or found”(etc)

I tried adding the bins but that did nothing…