Eclipse Development

I am trying to set up the plugins for Eclipse, and although I have updated Eclipse to the latest version, and Eclipse reports that the plugins are installed, neither the help section for it, nor the preference pane for it, nor any other reference to FIRST or FRC. Has anyone set Eclipse up yet successfully?

P.S. Running Mac OS X 10.5.8, Macbook

When you installed the plug-ins, did it ask you to accept a certificate? In that certificate accept pane, did you check off the first.wpi.edu certificate and then hit OK, or just hit OK? Eclipse has a strange property of allowing you to continue without accepting certs, and then just not installing anything with that cert - without telling you. If you go to the install new software page, on the FIRST update site, and they are still available for download (including being colored in to indicate they are still not installed) then this is the most likely issue.

Otherwise, please give me some more details about you eclipse install.

Also, note that once the plug-ins are installed (or before), they will need Eclipse to be setup to use the Java Development Kit (JDK) instead of the Java Runtime Environment (JRE) - instructions on how to do this are in the help contents, which will appear once installation succeeds.

I can’t really think of any other reason for the install to silently fail - if you are getting an error dialog at any point, please tell what it says.

What do I click to accept the certificate? I don’t see any buttons with accept on them, all I see is an unlabeled checkbox.

I am running Helios Service Release 1: Build ID 20100917-0705

I checked the “what’s already installed” menu, and they do show up there, however, there is no trace of any functionality or documentation.

The unlabeled check box needs to be checked before selecting ok on that dialog. If that seems ineffective, I suggest uninstalling the plug-ins and trying again. If that doesn’t work, we can continue from there.

So, exact moment: After you have accepted the license, and during the time when it is installing, you will be presented with a dialog asking you if you trust such-and-such certificates. Check off the box next to the first.wpi.edu certificate, and then click ok - you are still able to click ok without checking off the box, but the plug-ins won’t actually install. I would recommend "uninstalling: the plug-ins and trying to re-install them, this time specifically checking off the certificate (I’m sure the first time it was just another dialog, don’t exactly expect you to remember if you did or not that time).

If this does not work, then please give me a step-by-step of what you did. Also useful would be the configuration details from your eclipse install - available at About Eclipse->Installation Details->Configuration (Under help for me, but I’m running windows, it may be under Eclipse of the far left for you)

Ok, I checked the box, clicked next, and if asked me to restart. I restarted, and again there were no signs of the FRC plugin. I tried again, and it still didn’t work. Should I try to install them manually somehow, or do something else? I included images.

http://www.mediafire.com/?wftadqk937b10z9
http://www.mediafire.com/?wftadqk937b10z9

I tried uninstalling, and the box was checked both times. Should I try to install manually, or should I do something else? I attached images of the menu:

http://www.freeimagehosting.net/uploads/fbdfc8802b.png](http://www.freeimagehosting.net/)
http://www.freeimagehosting.net/uploads/8c7494b696.png](http://www.freeimagehosting.net/)

I just reinstalled the plugins completely, but still nothing shows up. Is there a way to install them manually?

plugins.png.zip (230 KB)




plugins.png.zip (230 KB)

Alright then…

Next step is to see if Eclipse is trying and failing to start the plug-ins. In the folder you are using for your workspace, there is a folder called “.metadata”, and within that a file called “.log”. this will contain any stack traces Eclipse threw. Could you please provide that file? On a mac, these files will be hidden, as they start with a “.”, so you will have to turn on showing hidden files/folders. If there is no .log file even after showing hidden items, then no stack traces were generated.

Ok, I attached the log files, but in a ZIP format because they were too big for the forum (420 KB then, 20 KB now).

log.txt.zip (16.9 KB)


log.txt.zip (16.9 KB)

Looking at the logs, I see a lot of exceptions relating to equinox. Did you just update to the latest version? And by latest version, do you mean Helios?

I can’t see any exceptions which trace back to the FRC plug-ins… maybe the other exceptions are preventing them from loading?

The easiest thing to do might be to grab a new copy of Eclipse and start fresh - which would at least remove most of the variables in this situation, though I know that probably isn’t the preferred solution for you to go with.

Also, you could try deleting the .log file, opening eclipse, and then closing it (assuming there is still no sing of the FRC plug-ins) - this would give me a log with only one run attempt in it.

The FRC plug-ins do not interfere with any other plug-ins, but they do use other plug-ins (hence dependencies) and if those plug-ins are failing to start for some reason that could cause Eclipse to skip them. However, given that nothing seems to trace back to the FRC plug-ins in the logs (a lot of it is referencing UI actions on widgets, which would require the plug-ins being loaded and visible in the first place).

Yes, I just updated to the latest version of Helios (now the version is Helios Service Release 1, Build id: 20100917-0705). I have absolutely no idea what equinox is, but from the about page, I take it is the plugin architecture. Is there configuration that needs to be done there for the FRC plugins?

Just started with a completely new Eclipse install, and a new workspace, but still no sign of installation, other than the installed software window.

I attached the log file, but still no mention of the FRC plugins.

Where could I find a list of dependencies, because I agree, this would be a probable cause.

Also, I found another interesting menu: There is a startup menu, which contains a few plugins, but does not contain the FRC plugins. Do I need to add them to that list somehow?

Just as a test, I’ll try the same steps in a Linux VM. Then we’ll know if it’s just Mac, or if it is Eclipse.

log.txt (1.58 KB)


log.txt (1.58 KB)

Where is this startup menu? The FRC Plug-ins should be added to that when installed (by the Eclipse installer). I don’t know why they wouldn’t be on that list, but they would have to be to work - anything Eclipse doesn’t startup knowing about cannot be activated at any time

It is in Preferences/General/Startup and shutdown. For me, this appears in the list:

Usage data gathering plugin
Usage data recording plugin
Equinox Provisioning Platform Automatic Update Support
Mylyn Tasks UI
Mylyn Team UI
Eclipse UI
Automatic Updates Scheduler

Also, I tried installing the plugin on linux (Ubuntu 10.10), and it simply said: “Cannot complete the install because one or more required items could not be found.” Are there prerequisites for the plugins? Maybe linux prerequisites would also apply to Mac OS X?

The prerequisites would take the form of required plug-ins, which Eclipse would automatically find and ask you to install - the only time I have encountered it saying that when I needed to upgrade versions entirely - though I would assume you are using Helios in Linux as well. Are you able to add FRC to your startup? And there is no help or anything showing, correct?

In linux, it just give me the error message, on Mac, they are reported installed but do not have any effect. I used helios on the Linux test, like you said. I cannot find any way to add plugins to the startup menu, unless they are there but unchecked, which is not the case.

Also, I found the plugin files in /Applications/eclipse/plugins, and three of the FRC plugins are folders instead of JARs. One of the files references an initializer as “edu.wpi.first.javadev.sunspotfrcsdk.preferences.initializer”, however, there is no plugin by that name, merely a sequence of folders that follows the specified order exactly. Do they need to be compiled?

No, they are extracted from jars to folders when installed. The preference initializer is a built-eclipse element.

I was able to get Eclipse up and running under ubuntu 10.04 by just follwing their instructions. A post on my blog might help those of you who are struggling.

Overall, I love these plugins. The robot centric view is amazing.

@GGCO

Great! I am glad to hear that they are working that well for you :slight_smile:

@enbug

Are the FRC “features” under the Eclipse features folder? if they are not then Eclipse may not be “seeing” the plug-ins as available to startup, - and Eclipse is not properly installing.

Is there anything about your computer’s sofware which sticks out to you as being very different? I am trying to determine the difference between your machine and the Mac/Linux we tested on (we have successfully installed to Eclipse on Mac and Linux before).

So, just to sum it up for those reading this thread:

-Eclipse plugins are installing but not starting up in Eclipse for enbug (help content and such does not appear)
-enbug has tried both mac and Linux, with fresh Helios install, and is correctly accepting certs
-During plug-in testing, the plug-ins have been successfully installed on Linux, Mac, and Windows
-Other users are able to install and use the plug-ins successfully
-Linux is giving errors about not finding required items, even though it should be finding available required items and asking for permission to download them as well

Also @enbug:

On the Linux install, when you first open the install new software window, do you have “Contact all update sites…” checked off? If not, this would explain it not just asking you if it is ok to install a dependency

Thank you for all your advice, but at two pages for just one person’s problems with the Eclipse plugins, I’m gonna throw in the towel, especially as others have installed it successfully on linux. If I find the solution, I’ll post it here, but it is a little crazy to have one thread for just my problems. Thank you so much for your time, Ryan O.