Eclipse fails build project

While using Eclipse to build our C++ projects on the lab computer the console outputs

Cannot run program "make": Launching failed

Error: Program "make" not found in PATH
PATH=[C:/Program Files/Java/jre1.8.0_25/bin/server;C:/Program Files/Java/jre1.8.0_25/bin;C:/Program Files/Java/jre1.8.0_25/lib/amd64;C:\frc\bin;C:\Program Files\Java\jre1.8.0_25\bin;C:\Program Files (x86)\Git\cmd;C:\Program Files (x86)\Git\bin;C:\Program Files\Java\jre7\bin;C:\Program Files\eclipse;]

Does anyone know what I have to add to our PATH to make it work?

See this post. You need to add the path the FRC toolkit path to eclipse.

Did you install the toolchain?

you’ll need to restart eclipse after installing it.

I am still having this issue in Eclipse. I have appended the environment variable with FRC and the folder the toolchain was installed in.

Is anyone still having this issues or know how to fix this issue?

Error: Program "make" not found in PATH
PATH=[C:\Program Files\eclipse-cpp-luna-SR1a-win32-x86_64\eclipse;C:/Program Files/Java/jre1.8.0_25/bin/server;C:/Program Files/Java/jre1.8.0_25/bin;C:/Program Files/Java/jre1.8.0_25/lib/amd64;C:\ProgramData\Oracle\Java\javapath;C:\Program Files\Common Files\Microsoft Shared\Windows Live;C:\Program Files (x86)\Common Files\Microsoft Shared\Windows Live;C:\Program Files (x86)\Intel\iCLS Client\;C:\Program Files\Intel\iCLS Client\;C:\Program Files\Dell\DW WLAN Card;;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Program Files\Intel\Intel(R) Management Engine Components\DAL;C:\Program Files\Intel\Intel(R) Management Engine Components\IPT;C:\Program Files (x86)\Intel\Intel(R) Management Engine Components\DAL;C:\Program Files (x86)\Intel\Intel(R) Management Engine Components\IPT;C:\Program Files\Dell\Dell Data Protection\Access\Advanced\Wave\Gemalto\Access Client\v5\;C:\Program Files (x86)\Security Innovation\SI TSS\bin\;C:\Program Files (x86)\Windows Live\Shared;C:\Program Files (x86)\IVI Foundation\VISA\WinNT\Bin\;C:\Program Files\IVI Foundation\VISA\Win64\Bin\;C:\frc\bin]

Are you trying to build one of the FRC projects? If so, double check to makes sure that Debug is the selected build configuration.

I will look this afternoon and let you know but I think I have tried in both debug and release modes. Still have the same results for both scenarios.

Just a gut feel here - if you manually change your path (right click on my computer…properties…Environment…doing this from memory…) When you find the path that looks similar to the path you reported above, put
at the BEGINNING of the path and see if that solves it.

My theory here is that your path is VERY long and possibly Eclipse is having troubles with it somehow - or there is a character in the path which is making Eclipse barf and so it’s never ultimately getting to the END of the path which does indeed show C:\frc\bin

Very interested to know the final fix if it’s not this stab in the dark.


I tried both debug and release modes yesterday afternoon with no luck. I also tried your suggestion bob with no luck as well. I have a friend coming to look at it Saturday will let you know my results.

So far editing the normal PATH and using eclipse to append to the PATH has worked (idk if it was that or the total reinstall of Eclipse, build tools and the NI software)