Eclipse Java Error----NEED HELP PLEASE---

Hello Fellow FIRST Members,

Hope it’s going great, I’m the programmer for my team and we wanted to test some servo’s using our last year’s robot but when loading the code I came across a peculiar error

BUILD FAILED
C:\Users\HawksOn\wpilib\java\current\ant\build.xml:349: Assertion failed boolean test.
Image of roboRIO does not match plugin.
Allowed image year: 2017 version: 8.
Actual image year: ImageRegExFail version ImageRegExFail.
RoboRIO needs to be re-imaged or plugins updated.

If anyone knows exactly what this means it would be very helpful. I tried updating the plugins, didn’t work, I tried re-imaging the robot, didn’t work, I tried re-updating the roborio, didn’t work. If anyone has any idea how to fix this feel free to comment. Sorry to disturb you and thanks for your help

Can you take a look at this thread? I think it might have your solution.