Eclipse Neon W/ Robot C++ Dev Plugins

I’m having trouble with updating/installing the C++ Development tools on Arch Linux 64bit after Eclipse updated to 4.6 Neon, the Java tools install fine, but when try the C++ tools I get:

Cannot complete the install because of a conflicting dependency.
Software being installed: Robot C++ Development 0.1.0.201603020231 (edu.wpi.first.wpilib.plugins.cpp.feature.feature.group 0.1.0.201603020231)
Software currently installed: C/C++ Development Tools 9.0.0.201606062011 (org.eclipse.cdt.feature.group 9.0.0.201606062011)
Only one of the following can be installed at once:
C/C++ Development Tools Core 5.11.0.201509131935 (org.eclipse.cdt.core 5.11.0.201509131935)
C/C++ Development Tools Core 5.11.0.201602051005 (org.eclipse.cdt.core 5.11.0.201602051005)
C/C++ Development Tools Core 5.10.0.201506070905 (org.eclipse.cdt.core 5.10.0.201506070905)
C/C++ Development Tools Core 6.0.0.201606062011 (org.eclipse.cdt.core 6.0.0.201606062011)
Cannot satisfy dependency:
From: WPILib_CPP_Robot_Development 0.1.0.201603020231 (edu.wpi.first.wpilib.plugins.cpp 0.1.0.201603020231)
To: bundle org.eclipse.cdt.debug.mi.core 7.2.0
Cannot satisfy dependency:
From: Robot C++ Development 0.1.0.201603020231 (edu.wpi.first.wpilib.plugins.cpp.feature.feature.group 0.1.0.201603020231)
To: edu.wpi.first.wpilib.plugins.cpp [0.1.0.201603020231]
Cannot satisfy dependency:
From: C/C++ Development Tools GDB/MI CDI Debugger Core 7.3.0.201506070905 (org.eclipse.cdt.debug.mi.core 7.3.0.201506070905)
To: bundle org.eclipse.cdt.core [5.0.0,6.0.0)
Cannot satisfy dependency:
From: C/C++ Development Tools GDB/MI CDI Debugger Core 7.3.0.201509131935 (org.eclipse.cdt.debug.mi.core 7.3.0.201509131935)
To: bundle org.eclipse.cdt.core [5.0.0,6.0.0)
Cannot satisfy dependency:
From: C/C++ Development Tools GDB/MI CDI Debugger Core 7.3.0.201602051005 (org.eclipse.cdt.debug.mi.core 7.3.0.201602051005)
To: bundle org.eclipse.cdt.core [5.0.0,6.0.0)
Cannot satisfy dependency:
From: C/C++ Development Tools 9.0.0.201606062011 (org.eclipse.cdt.feature.group 9.0.0.201606062011)
To: org.eclipse.cdt.platform.feature.group [9.0.0.201606062011]
Cannot satisfy dependency:
From: C/C++ Development Platform 9.0.0.201606062011 (org.eclipse.cdt.platform.feature.group 9.0.0.201606062011)
To: org.eclipse.cdt.core [6.0.0.201606062011]

Does anyone know a workaround or have a package backup in /var/pacman/pkgs/ they can send my way?

I noticed that this morning as well and am working with the other WPILib devs on fixing the plugins. In the meantime, you can get older eclipse package versions from https://archive.archlinux.org/packages/e/. I think eclipse-common and eclipse-cpp are the ones you want.

Thank you mathmogul, if there’s anything i can do to help you and the WPI devs just let me know.

Out of curiosity, how is the update coming? I just updated to Eclipse Neon to find that the C++ plugin isn’t installingfor me as well.

That would be due to it depending on stuff from Eclipse Mars. Hopefully they’ll fix it soon™.

Java works fine though.