Eclipse Plugin Maintaineer?

Is there anyone still maintaining the Eclipse plugin for the mcc compiler?

I’ve tried installing it on several versions of Eclipse newer than the one specified in the documentation for the plugin, and it mcc still doesn’t show up in the project list.

It would be nice to have the plugin updated for the latest Eclipse.

Is the plugin rev locked? That would be a drag.

…Duane

Hey, thanks for letting me know.
That’s odd. I haven’t actually tried it with eclipse 3.2 and cdt 3.1, but there is no reason it shouldn’t work. I’ll look into it. I’m sure it works with eclipse 3.1 and cdt 3.0. If you’re trying to use the cvs CDT (i.e, cdt 4) it most probably won’t work, because it has a new project model.
I haven’t had much time to work on the plug-in as of late.

Thanks for letting me know though.

Sorry to take this a little off topic, but do you are anyone else who uses eclipse think that adding a slightly improved editor would be nice. For example, rom would highlighted as a keyword, etc.

Hi Ben
I’ve been silently hoping the eclipse threads would wake up again, glad to see some activity. I should have posted myself. But I want you to know the eclipse support is highly valued, at least by our team.

However, we have not been able to make it work properly since the changes were made for 2006 FRC. What you did is very attractive - the ability to simply switch among multiple compile targets. We have some code which can run on any of the RCs since 2004, and being able to build for any target is really useful.

So - if you or somebody is willing to pull together a start-to-finish instruction for setting up with eclipse, including access to the newest plugin, I’d like to try to get set up again. For the moment, we’re back on MPLAB, and don’t like it very much.

Thanks
Bill

Hi,

Before, I get to work writing a guide which would be completely useless to you, what sort of problems are you having. Are you not able to build two different hex files, or do the hex files, when loaded onto the robot controller not work?

Theoretically, what is supposed to happen is that when you have selected the “FRC Robot- 2006” configuration, there should be a folder in your project called “FRC Robot- 2006” (or something like that) with all the output of compilation for the 2006 . If you select the “FRC Robot- pre-2006” configuration, there should be a folder called “FRC Robot- pre-2006” with all the appropriate compiler output for the 2005 RC in there.

Short answer is “can’t build”. Can you point me to, or send me a copy of, the most current plugin? Then I’ll set up the environment from scratch and detail the steps and problems in another post for your comment.

Thanks
Bill

I’m going to answer a lot of questions in one go.

  1. 2006 compatible: I took prograid’s plugin, added a lot more features to it, and used it for our team. The mod is in Subversion online, but you need a login to read it. (I’ll go fix that some time.)

  2. PIC C editor: I tried this at one point, but it is a much harder problem. This is partly because the toolchain only required XML, while the editor requires real Java code. The main problem is that the CDT provides no way to modify the language. This was compounded by the fact that it doesn’t really have facilities to differentiate between dialects. (I’ve heard that newer versions of the CDT will help with this…)

Also included in this project was an error parser for the MCC18 output. Much, much simpler. (Except for Eclipse problems, it might be done.)

If interested, I’ll make sure to post these publicly.

Im interested, whenever you have time.

Fedora Core 6 released today. w00t.

Yes, please, post whatever you’re willing to post.

We used eclipse exclusively in 04-05 season, but have never got it under control again since the new plugin and the dual processor capability. I would really like to get tooled up for development in eclipse again this year before competition time sneaks up.

Thanks
Bill

Please count me in on the list of people that are interested in seeing the above!

I’m also very interested in the error parser. Coincidentally, I’ve been working on getting our Eclipse environment to be more “turnkey” while putting our code into Subversion. Just today I’ve been having troubles with two completely clean installations of Eclipse for FIRST builds. Both installations have resulted in the error parser not displaying any of the mcc18 error output in the “Problems” tab. Without the error parser working, one of the biggest benefits of Eclipse is unusable.

I am using the following configuration:
Eclipse 3.2.1
CDT 3.1.1
C18 Tools 2.0.1 (from prograid / Team 254 site)
Subclipse 1.0.3

Any suggestions on getting the error parser to work would be greatly appreciated!

–ken

Wow, lots of replies in one day!

I would like to see the changes Astronouth7303 has made as well. Are they just changing the builder to Cygwin/MSYS make and removing the unnecessary error parsers, e.g. GLD, etc.

As for your problem with the error parser, go to the project properties for your project and select C/C++ Build, then look through the tabs until you see the one with a list of error parsers. Make sure that the one with GCCError in the name is checked. If you want to be safe, just check all of them. By the way, I’d suggest using the development branch of Subclipse, which is supposed to be better integrate with eclipse 3.2.

As for the PIC C editor, what I planned on doing was actually distributing the entire CDT with a modified C source editor, which would add the appropriate keywords. I just haven’t had the time to look through the source.

An MCC error parser would be nice, since MPLINK errors currently don’t show up in problems. However, compiler errors seem fine for me currently when using the GCC error parser.

I’ll try to put an updated version in the update site this week along with some instructions.

I’ll change it to use MSYS/Cygwin rather that mingw32-make. If this would cause problems for any of you, let me know.

Personally, I’d prefer to stick with mingw32-make as that can be used with the installation of only the one application; I’d rather not have to install all of cygwin if possible.

As for your problem with the error parser, go to the project properties for your project and select C/C++ Build, then look through the tabs until you see the one with a list of error parsers. Make sure that the one with GCCError in the name is checked. …
I’ve tried that but haven’t yet met with success. I’ll try making a new project from scratch with mcc18 to see if a “Hello World” program works okay; another programmer on our team reported seeing the parser problems previously when importing old code into a new project. I’m hoping that starting from scratch may fix it…

–ken

I tried tweaking the error parsers settings within the IDE to lots of different configurations (all set, only C/C++ set, only make and C/C++ set, etc.) in attempts to get the error / warning message parsing to function. None of my attempts work. The only errors that show up are the “make” errors – none of the line-specific errors show up in the “Problems” tab. I tried this both with our working Robot code and also with a “Hello World” program and had the same results in both cases. I was trying this with the newest compilation toolset I could find:

  • Eclipse 3.2.1*]CDT 3.1.1*]MCC18 2.0.1 (from Team 254)

Since I had not been seeing this problem before doing toolset upgrades, I decided to try an older toolset. An older toolset works just fine! Here is the toolset that worked for me:

  • Eclipse 3.1.2*]CDT 3.0.2*]MCC18 1.2.0 (from Team 254)

I tried determining which of the above changes was responsible for my problem, but haven’t had time to try all of the combinations. I speculate that the problem may actually be due to an interplay between different pieces of the toolset, rather than being caused solely by one of the new components.

If anybody has been able to get error message parsing working correctly with the newer toolset I list above, I’d be glad to hear about it! At this point, however, I think our team is likely to proceed for our fall term software training with the above toolset that we have working, since we are likely to need to upgrade for the build season anyway.

–ken

It almost sounds like we need a SourceForge project for this, or something…

As for the update to the CDT, I think we may be able to maintain a “patch” (technical term) for it.

When I make the page, the plugins will be at http://www.astro73.com/eclipse/.

As a note, I have been developing on Eclipse 3.1.

The problem is that MinGW turns flags like “/d” into "d:". I believe a win32-native version of GNU Make will surfice, though. (eg, http://unxutils.sourceforge.net/)

Ok, the plugin projects in their current state are online. Again, it’s http://www.astro73.com/eclipse/.

Thanks. I have a working eclipse environment again. I followed the setup guidelines from the white paper, with these additions/changes/notes:

  • eclipse 3.2.1
  • CDT from http://download.eclipse.org/tools/cdt/releases/callisto
  • unzipped the zip from your link above to eclipse/plugins instead of using jar from white paper
  • changed make command in properties/build settings to mingw32-make
  • set windows system MCC_INCLUDE environment var to c:\mcc18\h
  • set library search path in properties/tool setting/mplink/linker infomation to c:\mcc18\lib (how about a MCC_LIB env var for this?)

I did not figure out how to make mingw32-make the make command in some way global to all projects. It would be convenient to do this.

Thanks for this tool. It’s good to be back on eclipse.

I found a small problem. I open properties/c/c++build/tool settings/mplink linker/linker information and delete the one entry in “libraries included in linking”. This is because I would prefer to define all the libraries in the lkr file. Then I can “clean” and all is well. But if I close eclipse and reopen it, the entry is back. I can’t delete it permanently.

This would be the wrong thing to do. The zip is of the projects, not jars. It is for development.

The only plugin that is actually usable is org.eclipse.cdt.mcc18.toolchain. You can tell Eclipse to Export it as a Deployable Plug-in.

The rest of it is currently incomplete or having strange compilation issues.

I’m confused. The zip contains no jar file. You earlier instructions said to use that zip instead of the jar that comes with the white paper.

What I did worked, halleujah. But please let me know what I should have done instead.

Thanks - Bill

I took prograid’s plugin and modified it. It just so happens that it’s XML-only, so I’m not surprised it worked. (Everything appeared in the right place as far as Eclipse goes.)

As to how to correctly setup and compile this in the future:

Setting up the project:

  1. Go to File > Import
  2. Select “Existing Projects into Workspace”, hit “Next >”
  3. Click “Select archive file:”
  4. Click “Browse…”, and select the downloaded archive file
  5. Hit the checkboxes on all 5 projects
  6. Hit “Finish”

The projects, by default, will automatically compile.

To package them into jars:

  1. Make sure you’re in the “Plug-in Development” perspective
  2. Right-click on the project you want to package, select “Export”
  3. Select “Deployable plug-ins and fragments”, hit “Next >”
  4. Check the projects you want to export.
  5. Select export destination of choice.
  6. Make sure that “Package plug-ins as individual JAR archives” is checked. (Using “Include source code” is entirely your digression"
  7. Hit “Finish”

Allow to run for a few minutes. You will then have the approrpriate installable JAR. Make note of changes you made to the default configuration; I changed the internal name of some (most?) of the settings.

Note: All the directions above are based on Eclipse 3.1.2.

Has anyone used this under Linux? I have been using a makefile to compile the code for the robot, but I don’t think that the makefile that I am using is 100% correct. I am trying to find an alternative way to compile code for the robot under Linux.