Eclipse WPI Plugin Issue


We think there is an issue with our WPI plugin as when we click “Run As”, there is no WPI Deploy option. We have tried reinstalling the WPI plugins as well as Eclipse itself to no avail. Does anyone have any advice?

Any help is appreciated!!

I was actually having the same issues today (I also reinstalled Eclipse which did nothing to help unfortunately :confused: )

My problem was rooted in my messed up .project file. In the package explorer I had to click a ton of sub folders to actually get to the robot code, as opposed to the package explorer looking like this:

See, the .project file was messed up in only one of the branches in the git repository. Even though the .project file was fine for this particular branch, Eclipse was acting funky and I couldn’t deploy the code. To fix this, I deleted the local repository off of C:/Users/me/git/repositoryname, cloned the repository off of GitHub and when importing the repository into the package explorer as an existing local repository, I selected ONLY the branch with the correct .project file and NOT the whole repository.

If that doesn’t work check out Eclipse’s workspace/.metadata/.log for errors. Also, this link provides a more in depth troubleshooting for this simple fix does not work:

Hope that helps!

How did the project come into the workspace?

If you created the project directly in the Eclipse environment through New Project -> Other -> WPI Robot Project, it should have the deploy option. If you imported / opened project from file system, WPILib will not pick up on it and will not display the deploy option.

Well, I have met that situation before, and I updated my wpi plugins several times and restarted eclipse and it worked. For your situation, just try update the plugins many times, if it doesn’t work, try to create a new wpi robot java project and try if it can run wpi deploy

Sent from my iPad using Tapatalk